Cadillac Owners Forum banner

1 - 9 of 9 Posts

·
Registered
2014 xts
Joined
·
6 Posts
Discussion Starter #1
Hello folks,
Good day to you - hope God is good to you.

Okay, driving to Florida, poof:
~ Stability light display across the alert system.
~ Stability function button to the dashboard right does not work
~ T/C idiot light on, stability idiot light on and cruise control not working
~ turn car off, restart and idiot lights off yet function of all three not working.

what say you. A fuse? Or buy a new car? Thank you. (2014 XTS)

Pilager
 

·
Registered
XTS
Joined
·
1 Posts
For me, it was a cylinder misfire, many functions were not working but i kept driving it for more than a year, finally I replaced the engine ( cheaper than to fix a cylinder )!

Other functions will not work such as remote start, driving was fine other than when I stop the engine it started to shake slowly, this increased by time until it became uncomfortable then I decided to fix it,

hope it's not the case with you,

good luck.
 

·
Registered
Joined
·
61 Posts
Missfire is either a coil or spark plug. Did you run a compression test to see if you have bad rings or valvesxnot sealing properly? It's not really a reason to replace an engine.
 

·
Registered
'02 ETC CE, '04 CTS-V, '04 XLR, '13 XTS Platinum
Joined
·
2,831 Posts
I doubt someone is going to do a compression test when the two options they suggest for troubleshooting are fuse or vehicle replacement.
 

·
Registered
14 XTS Premium, 16 Lincoln MKC Reserve AWD, 14 VW CC Executive
Joined
·
67 Posts
Hub bearing gone bad, either front or rear. Get it replaced before it goes into reduced power mode. Happened to me twice already. Exact same alarms.
 
1 - 9 of 9 Posts
Top