Cadillac Owners Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
48 Posts
Discussion Starter #1
I have just begun to get a message on radio/driver info display which says something to effect that I need to get the vehicle stability system serviced. Seem to get this message within 1/2 mile of engine start.

Vehicle is a 2wd 6 cyl SRX. I am on dry pavement in So Calif, but presently on freeways about 120 miles/day for next week or two. It would be extremely inconvenient but not impossible to get to dealer for perhaps another 2 wks/1000 miles.

Does anyone know exactly what this message might imply? What causes this message to be sent? I don't want to get into an unsafe condition because it would be inconvenient to stop everything and get vehicle serviced but also don't want to pass on committments I have made if this is not a safety concern. Message has come on about once per day for last few days except yesterday when it came on 2x. Could it be something as simple as a dirty wheel rotation sensor?

Car has been well maintained. Just come back from a 3K mi trip to mountain states and back in June. Did not get warnings of any type during the trip but did have to have car jumped 2x due to CD changer cycling CDs all night while we were asleep. Have since had the radio changed out for new/rebuilt at local dealer which has solved the problem.

Previously had 1x of a traction control warning, several months ago, but I reset the T/C button, stopped and restarted car and haven't seen the message since. Car appears to drive normally even at this time.

Are the T/C and Stability control systems inter-related (i.e., T/C system a sub-system of the Stability control system? New tires were all General Grabber UHP and were sized as spec'd by Calillac for this car (i.e. 65s in front and 60s in rear), but could it be that size difference in tires and hence rotation speed could be driving the computer nuts?? Could one of the 4 tires be out of mfgr's spec for diameter?

Had 4 new tires put on just before trip.
 

·
Registered
('04 SRX N* AWD) '11 Lincoln MKT AWD
Joined
·
1,049 Posts
Very likely, as I just had mine replaced 2 weeks ago. It's in the column.
 

·
Registered
2005 SRX AWD V8
Joined
·
204 Posts
ok,
I answered this once before. I had low brake fluid, which lead to a random "service stability system soon" message. I filled the fluid just a little bit, and have never seen the message again. You may want to check your brake fluid first.
 

·
Registered
Joined
·
48 Posts
Discussion Starter #5
donjumpsuit,

The warning is now popping up several times a day. I checked brake fluid today and, sure enough, it is about 1/8th inch below the "split ring" (I thought split rings were only used on batteries - guess that was only in the olden days). I will go out tomorrow and buy some fresh DOT 3 fluid and top off to "split ring" and then see if the warnings go away.
 

·
Registered
2004 srx V-8 awd
Joined
·
482 Posts
donjumpsuit,

The warning is now popping up several times a day. I checked brake fluid today and, sure enough, it is about 1/8th inch below the "split ring" (I thought split rings were only used on batteries - guess that was only in the olden days). I will go out tomorrow and buy some fresh DOT 3 fluid and top off to "split ring" and then see if the warnings go away.
Did adding brake fluid solve your problem?:confused:
 

·
Registered
SRX
Joined
·
166 Posts
We just picked ours up from the dealer this afternoon after getting the Service Stability System warnings fixed. It was the steering sensor.
 

·
Registered
Joined
·
48 Posts
Discussion Starter #8
Bought new sealed can of DOT3 brake fluid this morning and added it. It took about 3 oz which is quite a bit for a relatively small reservoir. I was pretty sure that would cure the stability system warning. Didn't get any warning for next hour of driving and errands. Sure enough . . . it didn't. Got the warning several more times in this afternoon's travels. Now I've got to find a slot for getting it into the dealer.

Fortunately we have a very good dealer, Symes in Pasadena, for this vehicle and a very good service writer who has taken excellent care of us.
 

·
Registered
Joined
·
48 Posts
Discussion Starter #9
BTW, thanks to all for all of the help and ideas.

I'll post on this thread when the problem is fixed and I know what was causing the warning.

Thanks again.
 

·
Registered
Joined
·
48 Posts
Discussion Starter #10
It was the steering wheel position sensor. Mechanic who did the work said it is a fairly common failure item. Went about 1 1/2 months before dealer and I could find time in common to do the work. Fortunately, this is So. Calif and currently not much snow or ice or rain on the roads.

Thanks again for all of the thoughts and suggestions.
 
1 - 10 of 10 Posts
Top