Cadillac Owners Forum banner
  • Hey everyone! Enter your ride HERE to be a part of JUNE's Ride of the Month Challenge!

1 - 9 of 9 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
We bought our 2008 SRX 3.6 V6 a couple of years ago. I spent a bunch of time chasing weird electrical gremlins. TC system activates going 70 down the highway in July. I've changed just about everything sensor in that system that there is. Then one day it started running rough and finally died. So, we bought the wife a new Jeep, problem solved! But, I wanted to get the SRX running for myself cuz it is still a sweet ride. I put a new battery in it and it fired right up. I had some other things to fix, so I never really drove it, but it ran really well in the driveway. Got all the other fixed and took her out for a spin. Less that 5 miles later without warning it just shut off. No security light, no engine light, nothing. Now, when I turn the key, I have an engine light that had a p0628 code so I thought fuel pump, but a fuel pump wouldn't cause a no crank/ no start, would it? The other thing I am thinking is an ignition circuit issue. I am at a loss here and can't seem to find a wiring diagram anywhere that is of any use. I also thought security, but wouldn't that light stay on?

TIA
 

·
Administrator
2002.5 F55 CORSA STS, 2014 Explorer XLT FWD
Joined
·
73,388 Posts
Welcome to CF !!

Maybe further info and diagnosis in the GM/Cadillac online service manuals in www.alldatadiy.com.

A fuel pump circuit fault should not cause a no-crank situation.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #4 ·
So, I got a subscription and spent all day chasing different components in the ignition chain. From what I can tell, there is no signal coming to The fuel pump relay or the starter relay. I'm thinking it might be a fried ECM because I do get a signal to the ignition relay to close when the key is turned to run. Also, the check engine light is on but there are no codes now. It says there are no codes stored in this module when I search all three modules, the ECM, the BCM, and the TCM. Thoughts?
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #5 ·
So, I got a subscription and spent all day chasing different components in the ignition chain. From what I can tell, there is no signal coming to The fuel pump relay or the starter relay. I'm thinking it might be a fried ECM because I do get a signal to the ignition relay to close when the key is turned to run. Also, the check engine light is on but there are no codes now. It says there are no codes stored in this module when I search all three modules, the ECM, the BCM, and the TCM. Thoughts?
Also I checked every single fuse in all three fuse boxes, nothing is blown. I even checked them with my ohmmeter.
 

·
Registered
2018 Cadillac XT5 Luxury
Joined
·
1,308 Posts
Where did the vehicle come from? Has it ever been in a flood?
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #7 ·
Where did the vehicle come from? Has it ever been in a flood?
Sorry for the radio silence! Been dealing with family health issues

It was a NJ car and it didn't say anything about flood damage in the Carfax. But a flood would explain a lot! I'm going to dig into more today.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #8 ·
Update!!!! It was the ECM/IGN fuse! But it wasn't blown, it had somehow doubled the internal resistance. The ECM wasn't getting the correct voltage to send the "all clear" for the starting circuit. But put it on a fuse tester and checks out just fine! She's back on the road now!
 

·
Registered
2019 XTS Luxury AWD, 2004 SRX N* AWD (gone)
Joined
·
2,389 Posts
Update!!!! It was the ECM/IGN fuse! But it wasn't blown, it had somehow doubled the internal resistance. The ECM wasn't getting the correct voltage to send the "all clear" for the starting circuit. But put it on a fuse tester and checks out just fine! She's back on the road now!
Thanks for the update.
 
1 - 9 of 9 Posts
Top