Cadillac Owners Forum banner

1 - 20 of 21 Posts

·
Registered
Joined
·
32 Posts
Discussion Starter #1
Ok, the wierdest thing happened when I was on the highway last night. I was cruising along like normal when my tc and abs lights turned on. Immediately following, my speedometer went to zero. Then my check engine light came on. After a while, the tc and abs lights turned off and the gauge worked ok only to have it do it again 5 mins down the road. Any ideas?
 

·
Registered
Joined
·
81 Posts
not sure how the speedo in the catera works, but if its anything like the old style cable ones, it could be condensation/frost on the magnetic pickups behind the gauge.
 

·
Cadillac Technician
none
Joined
·
11,051 Posts
Yep, the speedometer on Catera comes from the speed sensor reading on the right rear ABS sensor. If the EBCM takes a dive it won't send data to the ECM or the IPC on Vehicle speed. Your ABS/TCS lights should be on also and likely your check engine light too.
You need to get the EBCM replaced (brake control module) and I hope you are sitting down when they tell you how much it costs.
It's not really much of a DIY job either.
You need a handful of tools to reach into tight places. It's not very fun to replace.
 

·
Registered
Joined
·
188 Posts
Was it raining, snowing or really cold when it happened ???

Does the speedo work now ???

Before you replace anything I would inspect all electrical connections to the wheel sensor and the module.
Clean if necessary and apply some dielectric grease.
Check the fuses for corrosion and clean if necessary.
Leave the batteries ground disconnected over night and see if it does it again.

K.I.S.S.

You can always replace parts later but I would try the free things first.
 

·
Cadillac Technician
none
Joined
·
11,051 Posts
Actually boris, that's right.
It should be properly diagnosed to see if any outside influences are acting on this system.
There are as boris points out, many possibilities.

I didn't mean to jump to conclusions, you should have it checked to verified but to be frank, I have never seen anything that made a Catera speedo quit except for EBCM failure. That doesn't mean it couldn't be something else though.
 

·
Registered
Joined
·
188 Posts
ewill,
I'm not saying I'm right, all I'm saying is to eliminate all other possibilities.

The issues I have had with my electronics thus far have repaired them selves after I cleaned electrical connections and disconnected the battery to reset the system( disconnecting the battery a few times seams to fix just about everything):histeric:

The biggest problem I see with these cars is the fact that the US spec electronics were installed as an afterthought (or at least that's what it looks like) and they overcomplicated the whole situation.

With my '97 I replaced the main power and ground wires with 0 AWG (known as the big 3 on car audio sites) and have taken apart just about every electrical plug that I can get to.
All had signs of corrosion which I'm sure caused extra resistance.

Could that extra resistance be the culprit of many if not all the electronic malfunctions ???
 

·
Registered
Joined
·
32 Posts
Discussion Starter #9
K, I'll check that. It was just cold when it happened. No rain or snow. It goes back and forth now. It works then it doesn't. Tach never goes out though. It also feels like the power steering goes out at the same time. I'm going to autozone to get the codes though.
 

·
Registered
Joined
·
32 Posts
Discussion Starter #11
Ok, it came up with two different codes.

U2108 - Manufacturer specific DTC
P1700

Any ideas?

Thanks for your help guys. I love this forum.
 

·
Cadillac Technician
none
Joined
·
11,051 Posts
Yep, sounds like the EBCM is going bad.
The P1700 sets because the TCM loses VSS signal and tells the ECM to turn on the MIL.
The U2108 means the EBCM is not responding which is actually the source of the U1700 code like I just said.
 

·
Registered
Joined
·
21 Posts
i have the same problem in my 99 catera but my question is...is the ebcm bad even if it works sometimes? in my case it works when its very cold (chicago winter). i thought it might've been wiring but i dont know better any ideas? like i said my TC and ABS light is on most of the time and it goes away when its very cold ..weird!!!
 

·
Registered
Joined
·
21 Posts
i have the transmission light on as well ..i changed the TCM and it didnt do nothing ..maybe i have to do something else when replacing it like reset the codes i dunno any ideas??? do u guys think i have a wiring problem its a 99 catera
 

·
Cadillac Technician
none
Joined
·
11,051 Posts
This will also turn on the transmission light, because there is no Vehicle speed signal the TCM will set codes because it doesn't know how fast the car is going.
Need to replace the Brake control module.
EBCM
 

·
Cadillac Technician
none
Joined
·
11,051 Posts
I have gotten some from salvage cars, but it's a crap shoot.
No guarantee that you won't go to all the trouble of installing it and have it do the same thing the next day or 6 months later.
I know the GM one is very expensive but at least it comes with a 12/12 warranty.
 
1 - 20 of 21 Posts
Top