Cadillac Owners Forum banner

1 - 20 of 23 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
We have a 1999 Catera and are having some electrical problems.
When we start the car up in the morning the check engine light is on. Every thing seems to be working correctly. Runs good. After a little while of driving the speedometer quits working and the ABS and Traction Control light comes on. When this happens it is also hard to steer. The codes that come up are
U2108 - CAN Bus Error ABS
U2108 - Lost Comm with ABS Control System
DTC P1700 Transmission Control Module

If we let it set for awhile when we start it up the ABS and TC lights are off and the speedometer works but after driving for awhile the speedometer quits working and the TC and ABS lights come on.
Any suggestions on how to fix this problem are appreciated
Thanks
Jeff
 

·
Registered
None :(
Joined
·
2,703 Posts
Because the speedometer isnt working and you get the TCS/ABS light , it could be related to the Vehicle Speed Sensor which also works with the ABS system and of course, the speedometer. A link may be broken there, sensors bad, or the TCS/ABS module is having problems calculating both.


What do you mean by hard at steering when this happens? Does it feel like the powersteering has been cut off or...?
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
When the speedometer quits it gets hard to steer. I was thinking that maybe the powersteering was speed sensitive. The power steering seems to be working but it is very hard to turn.
Thanks
Jeff
 

·
Registered
None :(
Joined
·
2,703 Posts
jroberg said:
When the speedometer quits it gets hard to steer. I was thinking that maybe the powersteering was speed sensitive. The power steering seems to be working but it is very hard to turn.
Thanks
Jeff
Doh, i forgot... it is speed sensitive. :halo:
 

·
Registered
Joined
·
2 Posts
Hi,
I am new to this group but I am having the EXACT same problems as the other person. Sometimes the car works fine but 90% of the time the speedometer cuts in and out and the ABS, TC and check engine lights come on. My computer would not give a reading at all. But the speed sensor has been checked and appears to be working properly. Any other help that can be given.


Sean
 

·
Registered
None :(
Joined
·
2,703 Posts
There is a module that controls the ABS and Traction Control services- this goes to the transmission and the engine management. When its doing that all at once-in your case... id say it lost communications between one of those sources(it runs on a network). What do you mean by your computer? A code scanner i presume? Check the history's. Otherwise, its an electrical issue between one of these sources.

While your at it, are there other lights that come on? And when does it happen? What are the battery volts reading from the dash readout?
 

·
Registered
Joined
·
2 Posts
Hi,
Thanks for the quick reply. No other lights come on so far and the other problems that I mentioned are very intermittent. They just come and go on their own. No telling when! Let me know if you have any other suggestions.


Thanks,
Sean
 

·
Registered
Joined
·
5 Posts
I have a 98 catera and I am having the same problems. The car has gone to 2 seperate mechanics and it was just at the 2nd Cadillac dealer to try to repair this problem. I have over $700 invested into this problem and the best anyone can tell me is they don't know what the problem is. Is there anyone that knows what this ABS, Traction Control and Speedometer problem is?
 

·
Registered
Joined
·
57 Posts
interesting.. my speedo never stopped working, but the odometer stopped counting miles until i reset the trip meter.. lol
 

·
Registered
Joined
·
5 Posts
There is not an error code comming back it just looses communication. This past time they said they performed 3 different diagnostic checks and nothing came back. When the lights come on they lose communication. Now they say they can check further but they are not sure what it will cost but the service writer said it should be about $1500. But that is an estimate with no knowledge behind it. This seems to be a common problem, someone should know something.
 

·
Registered
None :(
Joined
·
2,703 Posts
It may be the vehicle speed sensor(s) in the transmission. Since the ABS and Traction control system utilize this also as a point of referance, if that malfunctions so does the ABS and TC. The vss (and the components related-speedo gear, and speedo wheel) is not an uncommon problem- but rare in some senses. Usually just the sensor assembly itself, not the speedo gear and/or wheel.. otherwise you'd need to get the transmission overhauled.

It would be a direct source of the problem if the ABS and TC arent malfunctioning. From the tests that the dealer did, im guessing those systems arent bad.

http://img.photobucket.com/albums/v125/MrHaun/VSS.jpg

#17 is the VSS.
 

·
Registered
Joined
·
1 Posts
pwnshp said:
Hi,
I am new to this group but I am having the EXACT same problems as the other person. Sometimes the car works fine but 90% of the time the speedometer cuts in and out and the ABS, TC and check engine lights come on. My computer would not give a reading at all. But the speed sensor has been checked and appears to be working properly. Any other help that can be given.


Sean

Hi
I'm also new, in fact I've registered Becasue I have the same problem. The local dealer couldn't fix the problem: ABS/TC lights, then Speedometer, then the power steering goes off.


Can anyone please tell me if changing the speed sensor solved the problem or not? and how much did it cost?

Thanks a lot.
 

·
Registered
Joined
·
5 Posts
I am going to replace the speed sensor this weekend. I am just waiting for the part to come in from Cadillac. I will keep everyone updated if this solved the problem or not.
 

·
Registered
Joined
·
5 Posts
What really makes me unhappy about this is I have a car with 60,000 miles, it is only worth $2,750 on trade in and Cadillac dealers cannot help me. It seems that Cadillac has just walked away from a $33,000 piece of garbage car and left Catera owners to suffer from a poor product. Before this happened I was going to look at the new STS but from the poor dealings with the cadillac dealers and paying for time and tests to be performed with nothing to show for it, I will never buy another Cadillac. BMW or Mercedes will get my business now.
 

·
Registered
Joined
·
9 Posts
Hi all,

I'm new to this group but came to it with the same problem. I took my caddy in to the dealer recently and the verdict was that the EBTCM (Electronic Brake/Traction Control Module) has gone kaput!
I was quoted $1,500 ($1,000 for the part and $500 for labor).
I've yet to get it done, but will let everyone know if it works. Kudos to you if you can install it yourself, because that will save you the $500 in labor. I've been told that the part is not too hard to find on the car, just a matter of having the time and room to operate.

If you do a search for "Cadillac Catera EBTCM", you should find a link to an editorial. I would paste the link myself, but I can't recall the policy of posting links.

Hope this helps.

Thanks,
Thom
 

·
Registered
Cadillac
Joined
·
2 Posts
I have the same problem. It all started the day I got my amp installed. Could that have anything to do with it since the power wire is connected close to the EBTCM and runs under the dash board where most of the relays are? My fog lights stopped working most of the time too. Sometimes they are on but lately not at all. And again, the fog light relay is located under the dash board. I hope it's not the EBTCM because the dealer wants over $2100 for it. (labour not included)
 
1 - 20 of 23 Posts
Top