Cadillac Owners Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
201 Posts
Discussion Starter #1
Hey folks

I've been having troubble with my speedometer on my 87 Brougham. I can turn the gear at the trans. by hand and the needle moves, but when I plug it in ...........Nothing. My haynes manual doesnt even mention a speedometer cable. What should that gear mesh with in the trans.?

Any help will be appreciate.

Thanks
 

·
Registered
1970 Sedan deVille hardtop
Joined
·
595 Posts
there is a gear on the output shaft of the trans that the gear meshes with. If you look into the hole that the speedo cable and gear came out of, you should see it. They are probably both plastic, might be chewed up.
 

·
Cadillac Technician
none
Joined
·
11,051 Posts
Yep, the trans drive gear is where you need to look.
Often times the square cable will spin in the gear, the hole is probably rounded out.
There are a couple of other possibilites, the drive gear on the output shaft of the trans could have broken it's retaining clip and moved away from the driven gear that you slide the cable into.
Take the bolt off the cover for the gear and slide it out, visually inspect those parts. You can buy a kit to repair it if it is the driven gear, you just have to match the color with the new part. They are color coded for how many teeth they have on them.
 

·
Registered
Joined
·
201 Posts
Discussion Starter #4
Thanks guys. I found both gears and the look ok. I think it has something to do with the gear form the cable moving out of possition. Ive been fiddling with it soo long now nothing makes sence any more. I cant find any obvious problem.
Later
 
1 - 5 of 5 Posts
Top