Cadillac Owners Forum banner

1 - 8 of 8 Posts

·
Registered
Catera
Joined
·
6 Posts
Discussion Starter #1
Hi, I'm Robb from the mid-Michigan area and I'm thinking about buying my brothers 99' Catera. It has some issues. The one that annoys me the most is the speedometer is off. The only time it's right is around 55mph. If I want to go 30mph the speedo reads 40mph. When above 55mph the speedo is off the other way. If the speedo reads 65mph, I'm actually going about 74mph:hmm:. The gas gauge doesn't read right either. I did multiple searches on hear for this issue and came up with nothing. Thanx in advance for any help you guys can give me.
 

·
Registered
2000 Black Catera Sport
Joined
·
57 Posts
hey Robb,

Welcome to the forum, I too am having issues with my speedometer, does your odo and trip work? also do you have any tc or abs lights on your gauge cluster lighting up
 

·
Registered
Catera
Joined
·
6 Posts
Discussion Starter #5
hey Robb,

Welcome to the forum, I too am having issues with my speedometer, does your odo and trip work? also do you have any tc or abs lights on your gauge cluster lighting up
Thanx.
Yes, trip and od both work, and no idiot lights whatsoever are on. It just seems weird that under 55mph its off one way, it's dead on at 55mph, then it's off the other way above 55mph. We put a scanner on it and it throws no codes.
 

·
Registered
2000 Black Catera Sport
Joined
·
57 Posts
i dont know whether to tell u to get a new cluster off of ebay or get the abs module rebuilt, could be a short also, wish some other guys would chime in on our issues
 

·
Registered
1999 Catera Sport
Joined
·
677 Posts
Sorry guys, if it were a common issue you've have several replies by now. I myself have never had this problem. Good luck.
 

·
Registered
2000 Black Catera Sport
Joined
·
57 Posts
I am thinking about changing the speed sensor on mine, the part is 68.00 on rock auto, maybe you should change yours also this may be the problem.
 
1 - 8 of 8 Posts
Top