Cadillac Owners Forum banner

1 - 6 of 6 Posts

·
Registered
1994 Sedan DeVille,and a 1984 ElDorado
Joined
·
9 Posts
Discussion Starter #1
Well I am back again! now it is acting really crazy? well sometimes for no reason the gas gauge will show Empty,and start flashing,even when it is full??? and the when I pull my headlights on,the chime goes off?? WTH????oh and when this is all happining my A/C stops blowing cold? then as I'm driving just out of the blue it clears up and the guage works,the lights come on without the chime, and A/C will freeze you out of there!!!! can anyone PLEASE HELP ME !!!!!
I personally think it is a short,but what do I know?:confused:
 

·
Registered
2010 Cadillac Premium AWD CTS
Joined
·
710 Posts
I would start by checking your battery connection. If you have corrosion the the cables, the contact will not be too good. I had a similar problem when my battery was going bad. I purchased an optima one and it all corrected itself. Other will hopefully chime in and help you diognose the problem. Good luck!

David
 

·
Registered
1994 Sedan DeVille,and a 1984 ElDorado
Joined
·
9 Posts
Discussion Starter #5
where should I look for the ground wires, other then the obvious batt grnd, chasis grnd, are there any others that I may have over looked? because I just bought a brand new optima batt, and it didn't help much other then it starts alot quicker now!!! by the way, thanks for the help so far !!!!:)
 

·
Super Moderator
White Diamond '03 DHS (with DTS floor shift)
Joined
·
86,990 Posts
There are many grounds. A FSM will show them all and it would be invaluable. Ebay is your friend.
 
1 - 6 of 6 Posts
Top