Cadillac Owners Forum banner

1 - 20 of 480 Posts

·
Registered
2009 SRX-4 Sport / TriCoatWhite
Joined
·
1,185 Posts
Discussion Starter #1 (Edited)
Anything wrong with your SRX out of the box ?????

I'm getting ready to take my 09' SRX to the shop to get those "little things" fixed.

These are the things I hope to have worked on!



NAV/RADIO WILL NOT TURN OFF:

When the Power Button is pressed, instead of the unit going off and “dark”, it goes quiet, and presents a very annoying bright blue screen. Should not be presenting blue screen. Screen should go off and dark when hitting power button off. Current work-a-round is to go Menu/Display/Display OFF then turn Volume Down. This gets annoying sometimes. I have no clue with the dealership will do with this one!


DRIVERS SIDE MIRROR:

Drivers side door mirror has reflection mirror flaws, which cause a ripple in the View. This is annoying and distracting, especially at night. I hope to get GM to replace glass! * NOTE: No – it is not the window tinting or glass, verified with window down.

Also: I'll have the dealer check heating system on Mirror – Drivers Side Mirror takes 3 Times as long to clear fog/mist/ice as passenger mirror, indicating a flaw in the heating system.


TRANSMISSION SHIFT PROGRAMMING:

Transmission down shifts from 5th to 4th way too easily and too often when in drive, especially on the highway with Cruise engaged. With slight acceleration or slight incline without acceleration the car will lurch and downshift. This is actually very dangerous when running with cruise control as it causes the car to lurch forward unexpectedly. Can’t run cruise on highway, if there is the slightest incline, unless you remember to put shifter into sport / manual mode – 5th.

Putting Shifter in M5 stops the annoying down shifting, but then you have to remember to put it back into drive for stops and town driving.

I am hoping the dealership will reprogram computerized transmission shifting parameters.


DRIVERS DOOR DROPS:

Drivers’ door “drops” when Opening. Please adjust so this won’t create problems in the future. The other doors seem to align fine.


WATER DRIPS:

AC drips cold water on Drivers Foot. My Wife expressed concern of damage to expensive shoes. I'm am concerned because drips turn into floods with cars!
 

·
Registered
91 Allante (gone), 06 SRX (gone)
Joined
·
4,396 Posts
I had my driver mirror replaced under warranty a few months ago, at about 42K miles. It still warms more slowly than the passenger mirror, but it does work eventually.
 

·
Registered
2011 CTS-V Coupe A6 w/RECARO's
Joined
·
345 Posts
So far I have only ONE complaint with my CPO 2009 V6 RWD SRX that has 20,500 miles on it, and ONE observation.

Complaint: The omission of Bluetooth.

Observation: Poor fuel mileage. We just went through 10 days of abnormally HOT weather here in St Louis and I was surprised how much of an impact it had on my MPG. It dropped by a full 2 MPG. I fill up every Sunday and religiously track my MPG by HAND. But even under ideal conditions its fuel mileage is bad.

Else my wife and love our pre-owned 2009 SRX and we are very picky. Hell I've already applied 6 coats of Zaino Z2-PRO. The Crystal Red just glows and looks a foot deep. It's spectacular.

I am thinking how nice some chrome wheels would look. So I'm out looking for some OEM 18" chrome wheels.
 

·
Registered
'07 SRX V8 AWD 20" Sport
Joined
·
112 Posts
I got my 2007 slightly used at 9k miles, so I am not sure what was fixed prior to me getting the vehicle, but here is my list of issues:

1. Cruise Control stopped working(computer was reflashed)
2. brake pads had to be replaced at 15k miles (did it myself, got perf ceramic pads)
3. Ultraview or something above driver side head creaks in sub 50 degree weather(never resolved after 3 dealer visits, now I am just used to it)
4. The glass panel on the top of the car that covers the ultraview motors shattered as I went over a pothole or something(insurance covered 50% of new panel, I installed myself)

I think that's all and I have 36k miles now. Its a great highway cruiser, so smooth and very comfortable. Overall I am very happy with it.
 

·
Registered
08' SRX
Joined
·
24 Posts
I lease my 08' SRX V6, and surprisingly very little problems in the 18 months I've had it.

Slightly squeaky brakes, when going backwards out of driveway in the morning.
Need a wheel alignment badly, cause rear tires are starting to wear on the outside of the treads.
Tranny doesn't shift the smoothest, but i'm immune to it, cause my Mazda6 Jatco isn't exactly the smoothest ATX around.
Nothing else at 15k miles. (knock on wood)
 

·
Registered
2008 SRX V8 AWD Sport
Joined
·
196 Posts
I bought my new 08 in October of 07. Within a month I had a problem with the valve train clatter at start up. It was fixed and I haven't had a single issue since. 24,000 miles now.
 

·
Registered
2008 V6 SRX4
Joined
·
61 Posts
I really love the car in the highway, but if I am going to nit pic I am going to have to say I hate the ridiculously wide walls to either side of the cargo space. The subwoofer (essentially useless) and the onstar system ( i like) are built into the sides of the cargo area and they rob at least 2-3 inches per side of storage space and cargo room. Storage place in general is kind of weak. I could also have done without the bose system, an amp on each speaker sounds like a horrible waste of space and resources.
 

·
Registered
2007 V8 AWD
Joined
·
109 Posts
The only thing I can think of is the passenger seat lumbar switch is a little loose. Design-wise, the side bolsters on the seat bottoms were too firm, so I went to an upholstery shop which cut out a center section and replaced it with softer foam padding. Visually identical, but more comfortable on long trips.
 

·
Registered
Cadillac
Joined
·
32 Posts
08 SRX: only problem in 18000 miles was the right windshield washer sprayer cracked at the base and sprayed water on the engine rather than the windshield. Cheerfully repaired in < 1/2 hour by Fitzgerald Cadillac in Frederick MD.
 

·
Registered
Cadillac SRX 2006
Joined
·
12 Posts
my 2007 has front turn signal/daylights burning out three times now, dealer has replaced it each time, but keeps on burning lights out, it is shame that they can't correct it and the pain of having to do all day job for a bulb change, other then that it is a great highway car

:)
 

·
Registered
2007 V8 AWD
Joined
·
109 Posts
Easy to turn off daytime running lights (unless you have a Canadian car): just rotate outer ring on left control stalk towards you.
 

·
Registered
2005 SRX N*V8 RWD; 1999 DeVille Concours
Joined
·
514 Posts
my 2007 has front turn signal/daylights burning out three times now, dealer has replaced it each time, but keeps on burning lights out, it is shame that they can't correct it and the pain of having to do all day job for a bulb change, other then that it is a great highway car

:)
We had our left TS/DLR lamp "go out" 2 times, but neither time had the lamp failed. The problem was the plastic lamp-base had warped just a bit but enough to break the electrical contact in the socket. (We now have 2 "good spare" lamps with warped bases) We searched for a replacement lamp with other than plastic base, found one with a bakelite base and problem appears to be solved. Suggest checking your old lamps.
Good luck.
 

·
Registered
2009 SRX-4 Sport / TriCoatWhite
Joined
·
1,185 Posts
Discussion Starter #13
Update:

I am starting to think I got a lemon!

I haven't taken my SRX in yet for the issues I listed opening this thread, Instead I decided to wait a bit, build a list, and then have everything fixed with one drop off.

In addition to my original items I have had a couple more things show up.

The Chrome Laminate on the Drivers Interior Handle is cracking and flaking off, with very sharp edges that cut your finger when trying to open the door!

My Universial Garage Opener doesn't work worth a crap. If it works at all, I have to be within 10 feet of the door, and even then it takes 3 to 5 hits of the button before it does anything. ALL other remotes work from 100 feet away, including HomeLink remotes in cars. This is the ONLY Remote that gives me grief.

Very annoying to have to move my car around in my driveway to try to get the garage door to close. (No :: I refuse to order a hand held unit.. I already have one of those for one door because GM choose NOT to use HomeLink and that door only works with those.)
 

·
Registered
2005 SRX N*V8 RWD; 1999 DeVille Concours
Joined
·
514 Posts
Update:
I am starting to think I got a lemon! ......
My Universial Garage Opener doesn't work worth a crap. If it works at all, I have to be within 10 feet of the door, and even then it takes 3 to 5 hits of the button before it does anything. ALL other remotes work from 100 feet away, including HomeLink remotes in cars. This is the ONLY Remote that gives me grief.
Very annoying to have to move my car around in my driveway to try to get the garage door to close. (No :: I refuse to order a hand held unit.. I already have one of those for one door because GM choose NOT to use HomeLink and that door only works with those.)
Our 2005 SRX has the original eqpt 3 button opener (Homelink or ??) installed on the driver's visor; and it works with 1) a very old Chamberlain screwdrive unit with a frequency that you cannot even buy replacement remotes for, 2) a several year old Genie with settable code digital receiver, 3) a nearly-new Genie with "intelli-code?" changable codes.
All 3 activate from ~ 60-80 ft away regularly without fail.

What is your "universal" remote? Was it OEM with your SRX??
Good luck!!
 

·
Registered
2011 Escalade Premium Edition
Joined
·
196 Posts
2009 CPO V8 AWD

Had it now for 2 months. Only problem so far was the jack compartment leak which I fixed by adding sealant to the weatherstripping.

I personally like the shift programming for highway driving. I like the downshift when I want to gently accelerate.

The omission of bluetooth was a problem. I just finished installing a Parrot MKi9100 unit with the bluetooth lockpick and am pleased with the operation. It also adds ipod/USB connectivity which I wanted as well. There are some details of the install that I would be happy to share with anyone interested in this configuration.

I also added a class 3 hitch with the factory harness. Originally was planning to use the factory hitch but a) they were hopelessly backordered and b) I am happier with the 2 in receiver since I dont have to use a clunky adapter now.

My next project is mounting snow tires on some 18 in SRX rims. Got the rims on ebay and waiting for the TPMS units to arrive.

So I am a happy customer. I did purchase the GM extended warranty just in case. . .
 

·
Registered
09 silverado CC,SRX (N*), 07 Silverado crew 4X4, 2000 Impala
Joined
·
86 Posts
Just did the torque converter, luckily we have GMPP 2005 N* AWD 62000 miles.:crying: Now a hum has started:confused:. Not the radio, not the Load Level compressor. Think it is a fuel pump issue, sound like a tuning fork (constant tone pitch) sometimes louder, we hear it when we are stopped moving and when I hear it and shut off the ignition it goes away. Wife claims she hears it lower and behind her. going to wait until it is more consistent then we will bring it in.
 

·
Registered
2009 SRX-4 Sport / TriCoatWhite
Joined
·
1,185 Posts
Discussion Starter #17
Robersch... It is the Factory Visor Universal. Yes, I am thinking something is wrong with it because others state theirs works fine - and the fact that all other remotes in my household work fine opening these doors.

I can't use it on "My" door because my door is a brand that doesn't have a "Learn" feature. To add remotes you physically plug them into the head unit with a special plug and that syncs them so they work. My "HomeLink" in my mustang was perfectly happy copying my hand unit to open that door. But since GM decided to go with cheaper Generic Universal remotes, there is no "copy" feature like with HomeLink. Now - The Generics aren't bad remotes, they just don't work with as many head units, and can't copy a transmitter.

To that note :: My old Craftsman Head unit that I programmed to work from my SRX, only will remember 6 remotes. All 6 were being used (Family)... I removed my daughters hand held from the group, so I could program the SRX into the head unit. That didn't make my daughter very happy, but she doesn't live at home anymore anyway.

Also : My SRX did NOT come with that sexy lady that is driving in the SRX Commercial on TV. I am thinking about calling customer service and letting them know she is missing. I mean, if they included her in the car on the commercial, then she must be part of the deal! I wonder if she is an after market accessory!
 

·
Registered
2005 SRX N*V8 RWD; 1999 DeVille Concours
Joined
·
514 Posts
Robersch... It is the Factory Visor Universal. Yes, I am thinking something is wrong with it because others state theirs works fine - and the fact that all other remotes in my household work fine opening these doors....... But since GM decided to go with cheaper Generic Universal remotes, there is no "copy" feature like with HomeLink. Now - The Generics aren't bad remotes, they just don't work with as many head units, and can't copy a transmitter.......!
Interesting that GM changed for 2009. Our SRX is a 2005 and a friend has a 2008 SRX and both appear to be ~ identical; their SRX unit operates their garage door (genie), their community access gate (??), and their sons garage door (??); and all were programmed by the SRX controller learning from each of the separate remotes being activated.

Wish I could offer better info, but ....
 

·
Registered
2009 SRX-4 Sport / TriCoatWhite
Joined
·
1,185 Posts
Discussion Starter #19
Well... Here is an UPDATE!

I dropped my SRX off at the dealership (Elco Cadillac - great people!) on Monday - they kept it for a couple of days. They gave me a DTS with 750miles on it to drive. I learned that I didn't care for the DTS.

Below is a detail list... It upsets me a bit :mad:that with the two biggest things I took it in for, they are telling me can not be fixed - and that is the Nav Screen not turning OFF, and the transmission shifting like a mad hatter when in cruise on the highway. :rant2:

------------------------------------------
NAV/RADIO WILL NOT TURN OFF:

Tech says this is normal, and they can not make it go off. No TSB's or write ups about it. ((Does yours turn off when you hit the power button, or just turn into a big blue lightbulb like mine? Has anyone gotten a dealer to fix it?))

End of issue - GM will not repair.

------------------------------------------
DRIVERS SIDE MIRROR:

Dealer ordered a replacement mirror to fix ripple in glass and heating problem... YEA!

------------------------------------------
TRANSMISSION SHIFT PROGRAMMING

Tech says this is normal - no TSB's or Write Ups about it. ((Does anyone else's car do this "crazy shift" crap when in cruise on trips? Has anyone gotten their dealership to fix it?))

End of Issue... GM will not repair.

------------------------------------------
DRIVERS DOOR DROPS:

Dealer re-aligned all doors.. NICE! Closes with gentle push now.

------------------------------------------
WATER DRIPS:

Dealer could not reduplicate - blew out all drain tubes. (Considering it is much cooler and lower humidity lately, I figured they would not get it to drip - glad they at least tried. So we wait until next summer on this one.)

------------------------------------------
DOOR HANDLE CHROME COMING OFF:

Dealership ordered replacement handle - YEA!

------------------------------------------
GARAGE DOOR OPENER:

Dealership ordered replacement unit - YEA! This actually surprised me! I figured they would try to say it works how it works.

------------------------------------------
SEXY LADY MISSING.

Tech stated Sexy Lady only comes with certain V series and XLR Models. So I'm out of luck. But he did say I might be able pick up an after market girl at some of the high class clubs! He also indicated that used models were available online! :rolleyes:
 

·
Registered
2009 SRX-4 Sport / TriCoatWhite
Joined
·
1,185 Posts
Discussion Starter #20
Another Update....

So, I have my daughter and her baby in my SRX, and it is 50 degrees and she is cold... so I set the Air Temp to 75 degrees... after a while I notice it is not getting any warmer... so I set the temp to 88 degrees.... 10 minutes later it is about 60 degrees.

Bummer.. my heater isn't heating - - well.. actually the automatic temp control is not doing anything UNLESS you set it to MAX.. THEN the defrost kicks in and starts putting heat.

So.. if I switch Fan and Vent to Manual.. then heat to MAX, I get heat. If I don't do those things.. I get outside air temp.

NICE!

So, I received my note in the mail that the other parts are ready, so I guess I'll have them look at the heater control while they are fixing the other stuff.

I am ever so slowly thinking I should not have bought an American car! :confused::(:(
 
1 - 20 of 480 Posts
Top