Cadillac Owners Forum banner

1 - 5 of 5 Posts

·
Registered
2004 SLS
Joined
·
254 Posts
Discussion Starter #1
My 97 STS stopped blowing air from the front vents. That is, the blower fan and/or fans do not work for the HVAC. The rear passenger vent blows air(only at highest fan speed)....strange, because I can get heat from it.

Any suggestions would be greatly appreciated. Thanks in advance.
 

·
Super Moderator
2010 DTS
Joined
·
87,421 Posts
Start by checking the fuses and the connector to the blower motor. If that checks out ok, then it is likely a bad blower motor. Not uncommon.
 

·
Registered
2004 SLS
Joined
·
254 Posts
Discussion Starter #3
Blower connector was at fault. Cleaned pins with WD40. Wiggled it around. Bingo!

Your advice and time were greatly appreciated. Thank you.
 

·
Registered
2004 SLS
Joined
·
254 Posts
Discussion Starter #5
The problem re-occurred 3x since. At all times, I was able to get the blower working once again, by popping open the hood, and wiggling the connector. Since the weather has let up today, I inspected the connector further.

Upon closer inspection, I found the two outside pins(female) on connector were much looser than that of the center pin. That is, they had a wider opening becuse the receptor tabs were bent further out/opened up more. Possibly preventing the male pins (on motor) not to make full contact within.

I sprayed the pins with WD40. Inspected and cleaned for any deposits. Took a very thin nail, and bent tabs to close gaps. Pronto!
 
1 - 5 of 5 Posts
Top