Cadillac Owners Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
I had been having trouble with two codes; P0741 (Transmission Solenoid) and P0420 (O2 Sensor).
By moving the rear O2 sensor out of the direct flow of exhaust between the Catalytic Converter and the muffler by using a modified / deeper spark plug
non-fouler, it kept the P0420 code from returning.

Note: I regret not buying one of the adapters / bushings from online that is already modified or long enough for the O2 sensor to fit as the are difficult to bore
out with a drill. My Deville O2 sensor is the 18mm size but is with the tip it is longer than a sparkplug. I bought a "Help!" brand (#42002) from one the major
auto parts stores, but then had a machine shop drill (not the threaded part) the non-fouler so that the sensor would seat enough to get the threads started.

The P0741 would return before the required 8 of 9 monitors were "Ready". The Catalyst Monitor and The EVAP Monitors were always the last to "Ready" but the other monitors were much easier to set.
I believe that I have discovered my own somewhat modified version of a "Drive Cycle" that doesn't require going over 40mph or long distances.


In my state to pass the inspection process for my model Deville, all but one monitors must be in the "Ready" status and the "Service Engine Soon" must not be
illuminated. I was familiar with the published "GM OBD2 Driving Cycle" that I have read about on many sites but it would never completely work enough (all but 2 would "Ready") for my car to pass. So I tried driving slow for a few days in hopes that the light would go off; it didn't. I was out driving around but had
pulled over and stopped; While checking the status to see if the P0471 was current, pending or history I accidently cleared all the codes which put the car back at the beginning. Since the engine was already warm I shifted from park to "D", Pressed the "Traction Off" (button on the end of the gear selector) one time, then drove about 5 miles at under 40mph to a gas station allowing the car to coast down to 20mph just before stopping, to help some of the tests to set.
I let the car idle for a minute before shutting off and fueling. I put about 4 gallons of gas in so that the tank would be between 1/4 and 3/4 full as I had read
other OBD2 tests require. Then I restarted the engine, shifted from park to "D" and pressed the "Traction Off" button once and proceeded about 7 miles back to my home keeping the speed under 40 mph and allowing the car to coast down to 20mph just before arriving home. I let the car idle for three minutes and then checked the readiness of the monitors with a scan reader; All but three were set to "Ready". Two of those three that were not ready, I knew had been easily setting to "Ready" after a cold start. The SES was still out. Could this be?
How did the Catalyst Monitor that had been so stubborn to set before so easily have set now?
I shut the car off, took the keys, locked the doors and then restarted the next morning (after 9 hours). I did a cold start, allowing the car to warm up while
holding the brake with the car in gear with the A/C and Defroster wide open and headlights on bright until the water temperature gauge went up two clicks.
I then put the car in park and checked; The Oxygen Sensor Heater Monitor was now "Ready". I shifted from Park to "D', pressed the "Traction Off" button one
time and then drove under 40 mph for about 4 miles to the Inspection Station. I allowed the car to idle for a minute and hooked up the scan reader; the
Secondary Air pump Monitor was now "Ready". Now all but one (the EVAP monitor), were in the "Ready" mode and the SES light was still out.
My car PASSED inspection !
Later that day I drove over 45mph and the SES light came back on. I am good until next year when I will read this method and remember what to do.

----------

Correction; I meant P0741 Transmission Solenoid and not P0471.
 

·
Registered
NONE
Joined
·
4 Posts
Re: Slower Driving Method for my 2003 Deville vs the "GM OBD II Drive Cycle"

Thanks for this, dr2005!

I have been helping my elderly mother-in-law get her 2003 DTS smog tested, and driving the heck out of her car. The car sits most of the time, now since she lost her drivers license over a year ago, so even though it has 44K miles it, it get almost no use now. The battery ran down last spring (she never mentioned it to me) and it lost its codes for monitors, so when I took it for a smog test, it (of course) wasn't ready... I have never had this issue with my cars, so it was a mystery to me! The guy at the smog test center told me to just drive it, which was of little help.

I found drive cycle info on the internet, but after many cycles, the Catalyst monitor refuses to clear!

I will try your suggestions and am very glad to hear that I may have a low speed way to clear it, since my area is rural which has made the "normal" drive cycle hard to do... the long slow down and stop is almost impossible with flat topography!

Phil
 

·
Super Moderator
White Diamond '03 DHS (with DTS floor shift)
Joined
·
86,781 Posts
Re: Slower Driving Method for my 2003 Deville vs the "GM OBD II Drive Cycle"

Clear the codes. Drive it for a few days and then see if any codes reappeared. If so, you'll probably have to address that issue before it will pass an emissions test.
 

·
Registered
NONE
Joined
·
4 Posts
Re: Slower Driving Method for my 2003 Deville vs the "GM OBD II Drive Cycle"

I didn't think to clear all the other codes... I thought that that would be counter productive, since if a circuit shows a cleared, it would show cleared in any subsequent drive cycle anyway? In any event, the Catalyst code monitor reports that the Catalyst test never ran for any of the three drive cycles I drove today!

Do you mean that I should be clearing all the other monitors every time I drive it?

Is it fair to say that there are certain circuits that take longer to test out? Isn't Catalyst is one of them, including Evap?

Thanks for your reply and any further information you can provide.

Phil

----------

Oh... it just occureed to me that you mean trouble codes! No. There are no trouble codes coming up, the car is clean.

Just the Catalyst monitor not testing, and in California, that one has to clear! It is the only one that cannot be uncleared; even though any other one not clearing would not disqualify for a smog certificate!
 

·
Super Moderator
White Diamond '03 DHS (with DTS floor shift)
Joined
·
86,781 Posts
Re: Slower Driving Method for my 2003 Deville vs the "GM OBD II Drive Cycle"

Hard to imagine that a 44,000 mile car could have a bad CAT. I'd take it on a good long highway drive and get that CAT good and hot.
 

·
Registered
1992 DeVille
Joined
·
2,339 Posts
Not sure about your generations computer but I'm guessing this can't be cleared by unhooking the battery for a while?
 

·
Administrator
2002.5 F55 CORSA STS, 2014 Explorer XLT FWD
Joined
·
68,449 Posts
Re: Slower Driving Method for my 2003 Deville vs the "GM OBD II Drive Cycle"

Is it fair to say that there are certain circuits that take longer to test out? Isn't Catalyst is one of them, including Evap?
Unless you are able to perform an accurate GM Drive Cycle it will take a week or so of "normal' commuting to set all the emissions ready flags. Every time you "clear codes" the entire process begins from scratch.

If you repair a fault and don't clear it, its code will go to History after 3 successful start/run cycles during which the fault is not detected. The code(s) will automatically clear from History after 30, 40, 50 successful start/run cycles if the fault is not detected.

If the car's built-in code system, or a parts store scan, does not turn up any P codes and the car still somehow fails emissions for catalytic converter, something is very, very fishy somewhere. Cat efficiency/operation WILL set emissions P code(s). WILL.

"Codes" do not appear in the DIC info bar until you physically enter the diagnostic system by using the proper vehicle year/model group of instructions in the "How to pull codes" sticky.
 

·
Registered
NONE
Joined
·
4 Posts
Re: Slower Driving Method for my 2003 Deville vs the "GM OBD II Drive Cycle"

Wow, pulling the battery would be just as bad as what really happened to my mother-in-law's DTS...

the battery went flat due to inactivity. Then all the monitor codes vanished. After she got someone to come over and hook up her late husband's trickle charger to get the car running again. Then, called me to take it to get it smog tested!!! Little did I know that the codes had been cleared and, of course, it would not present itself "ready" to smog. I've driven it through almost a dozen drive cycles to get all the circuits to "test" BUT, the "Catalyst" circuit has not tested and I can't cajole it into running the test.

Sooooo, long story short... no, unhooking the battery might just be a setback. Thanks for the reply anyway.

Phil
 

·
Registered
NONE
Joined
·
4 Posts
Re: Slower Driving Method for my 2003 Deville vs the "GM OBD II Drive Cycle"

Final note on MIL's DTS...

Crankshaft sensors throwing codes, dealer thinks that may have been keeping Catalyst test from running... hmmmm. Told me that if throwing more codes after crank sensors are replaced, they would have to replace the ECM... WTF. That's what they did, and it cost $1900 once all was said and done... Ran great before and after. Imagine that! I am mad at the dealer and swear off even considering a GM in my future, even though I would have considered a Camero.

Thanks for all the comments and advice!

Phil
 
1 - 9 of 9 Posts
Top