Cadillac Owners Forum banner

1 - 4 of 4 Posts

·
Registered
93 STS N*
Joined
·
76 Posts
Discussion Starter #1
I've checked all my bulbs, and replaced them many times all are 100% good. My right signal light blinks quickly, which the left one click for maybe three flashes and stops, occasionally gets another 1 or 2 flashes on top. { This is when its morning and the dimmer is on or at night with dimmer }..... During the daytime when its bright when the auto dimmer is off, both signal work fine left and right, on top of that night or day one reverse light won't work and like I said above all bulbs are new. Kinda confused, or yeah with the dimmer on I can sometimes get the left signal light to work properly if I don't let it click in place but hold the signal light stick down slightly at a certain spot lol ODD?
 

·
Cadillac Technician
none
Joined
·
11,051 Posts
I would agree, did you look closely at the contacts in the bulb sockets?
Sometimes they will get corroded or burnt up from a failing bulb or poor contact. Also sometimes the sockets get poor connections inside the housings themselves, Turn the lights on or get the car to act up, when it's acting up move the black wire around in the socket, give it a tug and a push and see if the lights get brighter or act normally. If so the socket is bad.
Also look at the grounds. That's a little trickier as you have to know where they are located.
I don't have the manual for that, but sometimes they are located behind the carpet inside the trunk, near the tail lamps themselves.
If you have a waterleak in the trunk you could have broken or corroded grounds for the tail lamps. I know Sevilles were pretty bad for a few years about water intrusion in the trunk.

If need be I have access to a service manual, I can look up the ground locations for some of the tail lamps to help you isolate the right ones.
 
1 - 4 of 4 Posts
Top