Cadillac Owners Forum banner

1 - 5 of 5 Posts

·
Registered
2004 SLS
Joined
·
254 Posts
Discussion Starter #1
Symptoms remain even after rotating tires, thus, eliminating wheel. Not long ago, I replaced the knuckle assembly (used) because of wear and movement, still OK.

Is it possible that the wheel bearing is bad? If so, what are the symptoms such? Could it be anything else?
 

·
Super Moderator
White Diamond '03 DHS (with DTS floor shift)
Joined
·
86,990 Posts
Have the tires been inspected for radial runout? Have they been road force balanced?
 

·
Registered
2004 SLS
Joined
·
254 Posts
Discussion Starter #3
Hi Ranger: No, neither have been performed. Both tires on the passenger side are fairly new, with less than 1k miles of use. The wheels are straight, and balanced.

The symptoms are more noticeable at 40+ mph, especially on freeways. The shudder and vibe are much more noticeable on straight road driving conditions, without any turns.

She just turned 189k miles. Originally from Cleveland, she is now spending her silver years in The Golden State. My search for a replacement Seville these past weeks may have pissed her off.
 

·
Super Moderator
White Diamond '03 DHS (with DTS floor shift)
Joined
·
86,990 Posts
That'll do it, but if you are looking for a replacement it may not be worth doing a RFB. Just pretend you are married to it. Let her bitch and ignore her.
 

·
Registered
2004 SLS
Joined
·
254 Posts
Discussion Starter #5
I hit 190k since my last post. To celebrate this milestone, she leaked coolant all over my passener floor mat. It was a heater core. Took me about two hours.

Still have not figured out what is causing the vibe and shudder in the right rear area. I rotated tires, replaced the knuckle and wheel bearing assembly(2nd time in 6 months), and installed new sway bar links....but to no avail.

The shudder and vibe can be felt between 40MPH and 80MPH. At times, it feels like the wheel is going to fall off.

By process of elimination, the only things left are the a-arms, trailing arm, and shock. In addition, there is a possibility of rust damage to the subframe and/or shock mount. Need to look into it further. Any suggestions would be greatly appreciated.
 
1 - 5 of 5 Posts
Top