Cadillac Owners Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hi – new guy here
I have a ’96 Eldorado and am getting error codes:

P0716 (Input/Turbine Speed Sensor Circuit Performance) and
P0717 (Input/Turbine Speed Sensor Circuit No Signal)

which are causing the check engine light as well as the “Service Transmission soon” message to appear.

Question: How important is it to replace this sensor? I’m inclined to wait until something more serious needs work, but don’t want neglect of this item to be the cause of something worse.

Also, how easy is it to replace? I am not mechanically inclined but can follow directions.

Thanks for any help!
pk
 

·
Registered
Eldorado Touring Coupe
Joined
·
19 Posts
pkettle said:
Hi – new guy here
I have a ’96 Eldorado and am getting error codes:

P0716 (Input/Turbine Speed Sensor Circuit Performance) and
P0717 (Input/Turbine Speed Sensor Circuit No Signal)

which are causing the check engine light as well as the “Service Transmission soon” message to appear.

Question: How important is it to replace this sensor? I’m inclined to wait until something more serious needs work, but don’t want neglect of this item to be the cause of something worse.

Also, how easy is it to replace? I am not mechanically inclined but can follow directions.

Thanks for any help!
pk
hmmm... im pretty sure thats in the tranny. You got to drop it. $1,500 to fix at a dealer. Does your speedo still work?
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
jakej said:
hmmm... im pretty sure thats in the tranny. You got to drop it. $1,500 to fix at a dealer. Does your speedo still work?
Yes - the speedo works fine.
If the code is cleared from the sensor, it will usually return while the car is slowing down or idling.

Thanks for the reply.
pk
 
1 - 3 of 3 Posts
Top