Cadillac Owners Forum banner

1 - 7 of 7 Posts

·
Registered
2011 CTS V Black Coupe
Joined
·
43 Posts
Discussion Starter #1
We had a nice day up in Minnesota so I decided to take the 2011 CTS V Coupe for a nice long drive.. The car had not been driven for about a month and a half. The first time I apply the brake to slow down for a turn I can feel the veh shaking and the steering wheel was moving .. Never had this problem before ,,always smooth braking.. I tried braking hard a couple of times and it did get a little better but was still shaking...With my limited knowledge of brakes I'm thinking something is frozen or stuck but in reality I have no clue..I probably won't drive the car for a period of time, (snowfall, icy roads) if it remains the same I will take it in.. Does anyone have an idea of what is causing this I would love to hear from them..


Jerry (frozen and shaking) in Minnesota.
 

·
Registered
2011 CTS-V sedan, 69 Mustang Mach I
Joined
·
331 Posts
I would say you may have a little rust on the rotors. Do a few hard braking stops and it may go away.
 

·
Registered
Gone; ‘09 V, ‘13 V coupe. Curr; ‘14 PG Vsport prem w/Kona interior
Joined
·
6,177 Posts
69stangscj said:
I would say you may have a little rust on the rotors. Do a few hard braking stops and it may go away.
Yep. What he said.
 

·
Registered
2013 6MT V wagon, OBM, 2009 silver V sedan (traded)
Joined
·
4,537 Posts
Third. I have experienced this, too. HARD braking from 60-10 a few times will do the deed.
 
1 - 7 of 7 Posts
Top