Cadillac Owners Forum banner

1 - 4 of 4 Posts

·
Registered
Seville SLS 2000
Joined
·
9 Posts
Discussion Starter #1
My sls (66k miles) suddenly started to idle rough and sometimes is stalling when stopping. When driving hwy speed and taking foot of gas the engine will drop rpm and starts to surge. When hitting gas again engine will stall before pickup. Otherwise running ok when driving above idle speed rpm. Dealership said that engine is running lean and wants to replace fuel pump as pressure is only 35psi instead of required 45psi. I'm not sure if the fuel pump will solve this. Filters were replaced. Can some help with some more ideas of what could be wrong? tks Karl
 

·
Super Moderator
White Diamond '03 DHS (with DTS floor shift)
Joined
·
86,990 Posts
35 psi IS low. If it is lean, check for a vacuum leak. Do a search for "plenum". Common leak point on 2000+. And pull the codes.
 

·
Registered
Seville SLS 2000
Joined
·
9 Posts
Discussion Starter #3
I've found the problem! The workshop didn't reconnect the vacuum box that is on top of the air intake hose. They must have forgotten to put it back on. The engine is running very smoothly again. They (Cadillac Dealership) wanted to replace the fuel pump to fix the problem. Iim really angry about it and think I'm show'em my finger on Tuesday.
 

·
Super Moderator
White Diamond '03 DHS (with DTS floor shift)
Joined
·
86,990 Posts
Glad it was a cheap easy fix, but at 35 psi a new fuel pump may be in your future anyway. Just keep it in mind if it starts acting fuel related "funny".
 
1 - 4 of 4 Posts
Top