Cadillac Owners Forum banner

1 - 8 of 8 Posts

·
Registered
2002 Cadillac Escalade AWD 6.0L "Lady"
Joined
·
26 Posts
Discussion Starter #1
I know others have posted this, but wanted to give my experience with more description to see if it raises any red flags for the experts.

I have a 2002 Cadillac Escalade AWD 6.0L. When I start the vehicle, no lights in the DIC.When I start to drive the vehicle and turn the steering wheel, I experience what sounds and feels like the traction control and/or anti-lock break system activating, sounds like its coming form the front left. I makes the brrrp brrrp brrp a few times and eventually I get "Service Stability System" on the DIC, and it stops making the sounds.

I have replace the front left hub assembly, the problem remains.

I took it to the shop to have them diagnose the code. They told me it came back with codes for 3 components; electronic brake control module, yaw sensor, and something else I can't remember. The mechanic said he checked all the speed sensors and they are working. The mechanic mentioned that I could drive the vehicle with the code while he reached out to an associate that has experience with the modules to see if there is an issue that would cause all three to throw a code. I have not heard back from the mechanic, thought I would reach out to you armchair mechanics before I take it to another shop. This is not my daily so don't freak out, I'm not trying to rack up a bunch of miles on it until the issue is addressed.

Thanks!

Eric
 

·
Registered
2002 Cadillac Escalade AWD 6.0L "Lady"
Joined
·
26 Posts
Discussion Starter #2
Today I replaced the Yaw Module located under the cup holders in the center console, no success. I may try replacing the steering wheel sensor before sending it back to the shop to be sorted. I'd like to check the ground connections. Does anyone know where the ground for these stability system modules would be located?
 

·
Registered
2004 ESV
Joined
·
851 Posts
The 02 and 03s have different setups compared to the 04-06 models, so info I would pass along wouldn't be relevant for your vehicle.

Might be worthwhile to go to the GM site and get a 3 day access pass for the wiring diagram for your car. It's $20, and you can save and print whatever you want during that time.
 

·
Registered
Joined
·
177 Posts
I know others have posted this, but wanted to give my experience with more description to see if it raises any red flags for the experts.

I have a 2002 Cadillac Escalade AWD 6.0L. When I start the vehicle, no lights in the DIC.When I start to drive the vehicle and turn the steering wheel, I experience what sounds and feels like the traction control and/or anti-lock break system activating, sounds like its coming form the front left. I makes the brrrp brrrp brrp a few times and eventually I get "Service Stability System" on the DIC, and it stops making the sounds.

I have replace the front left hub assembly, the problem remains.

I took it to the shop to have them diagnose the code. They told me it came back with codes for 3 components; electronic brake control module, yaw sensor, and something else I can't remember. The mechanic said he checked all the speed sensors and they are working. The mechanic mentioned that I could drive the vehicle with the code while he reached out to an associate that has experience with the modules to see if there is an issue that would cause all three to throw a code. I have not heard back from the mechanic, thought I would reach out to you armchair mechanics before I take it to another shop. This is not my daily so don't freak out, I'm not trying to rack up a bunch of miles on it until the issue is addressed.

Thanks!

Eric
Do you drink a lot of liquids in the car or the past owner may have because there is a yaw rate sensor a little silver box right under the cup holder so liquids can spill down there and short the box. To take the cup holder assembly there are grooves on both sides where the holder meets the car pull up on the side closest to the dash then open the console door slightly but not all the way you may have to move the console door a little bit to get it out.
 

·
Registered
2002 Cadillac Escalade AWD 6.0L "Lady"
Joined
·
26 Posts
Discussion Starter #5
The 02 and 03s have different setups compared to the 04-06 models, so info I would pass along wouldn't be relevant for your vehicle.

Might be worthwhile to go to the GM site and get a 3 day access pass for the wiring diagram for your car. It's $20, and you can save and print whatever you want during that time.
Thanks I'll check that out.
 

·
Registered
2002 Cadillac Escalade AWD 6.0L "Lady"
Joined
·
26 Posts
Discussion Starter #6
Do you drink a lot of liquids in the car or the pas owner may have because there is a yaw rate sensor a little silver box right under the cup holder so liquids can spill down there and short the box. To take the cup holder assembly there are grooves on both sides where the holder meets the car pull up on the side closest to the dash then open the console door slightly but not all the way you may have to move the console door a little bit to get it out.
I replaced the Yaw rate sensor under the cup holder, but still get the SSS light. That was my suspicion as well, because someone definitely spilled a lot of drinks in the car. The old yaw rate sensor had some sticky soda on it, but I suspect it was sealed up tight enough to survive the spills. I may make one last effort to clean the connection, but I think the issue may be elsewhere.
 

·
Registered
Joined
·
177 Posts
Have you ever gotten a tire alignment on it or maybe the previous owner did. There is whats the Steering Wheel Angle Sensor and if it's not calibrated is can tell you Service Stability System or if the sensor is bad.
 
1 - 8 of 8 Posts
Top