Cadillac Owners Forum banner

1 - 5 of 5 Posts

·
Registered
1986 Coupe Deville
Joined
·
138 Posts
Discussion Starter #1
Hi I am directing this too the HT4100 experts. My 86 CDV running very nicely but on occasion my Service soon telltale light comes on and stays on.
when I shut off the car and restart its gone I haven't pull the codes yet. I thought I read that these lights are nortorious for going off for no reason.
Or maybe I have an O2 sensor going bad. any ideas I will post any codes I get ASAP.

Thanks
Tallpat
 

·
Registered
76 Eldo (54k), 76 Eldo (52k), 78 Eldo (9k), 85 Deville (43k)
Joined
·
668 Posts
Check your codes by pressing and holding "off" and "warmer," that should tell you what the issue is. Watch the Fuel Data Center for the codes and check the OBD I listing at the top of the forum page.
 

·
Registered
'87 SDV
Joined
·
1,296 Posts
Agreed. The SES light is almost always set by an issue that produces a trouble code. Since the car is running okay and the light is intermittent, my money is on a TPS adjustment or an EGR problem.
 

·
Registered
1986 Cadillac Sedan DeVille, 1998 Cadillac Sedan DeVille
Joined
·
75 Posts
Probably just a TPS error, mine did it all the time usually when I put the gas down and held it there, try letting up immediently and going lite on the gas when it comes on, or tap the pedal a few times, that worked to make mine go off, not really a problem, just a nuisance though.
 

·
Registered
1926 Model T street rod, 2000 Jaguar XJ8, 1999 Corvette.
Joined
·
6,738 Posts
These are at best, guesses. Perform the on board diagnostics and post the codes found. The service eng light always means something is working incorrectly or not at all. Upon restart, the ECM will wait to retest the faulty system and if still faulty, will turn on the light again.
 
1 - 5 of 5 Posts
Top