Cadillac Owners Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
92 Posts
Discussion Starter #1
My 97 Concours reads "Service Ride Control". I removed the battery for a few hours and replaced it and the code is still there. My ride is relatively bumpy and unsupportive (for a caddy). Does this mean I need new struts or shocks? My car spit out three codes, can anyone provide any info?
Here are the codes:

U1255
C1783
C1785

Thanks for any help!
 

·
Registered
Joined
·
3 Posts
service ride control

I have a 94 DeVille, the ride control light just started coming on and going of constantly. Nobody around me seems to know what it is but I been told it may have something to do with moisture. I have recently been using the car wash last couple of months. My guess is the Cadillac dealer will want about 1200.00 to fix. If I find the solution, I will post.
 

·
Registered
Joined
·
162 Posts
YUP Fellas your struts, usually the fronts are going bye-bye.
If they are the electric ones Mr. Dealer wants over 2k to
replace. As I found out on my 96 Deville !

Check www.caddyinfo.com site..they have pics and hints to shut off
the SRC message and/or how to replace with the cheaper
passive front struts. .............geo
 

·
Registered
Joined
·
3 Posts
sonjaab said:
YUP Fellas your struts, usually the fronts are going bye-bye.
If they are the electric ones Mr. Dealer wants over 2k to
replace. As I found out on my 96 Deville !

Check www.caddyinfo.com site..they have pics and hints to shut off
the SRC message and/or how to replace with the cheaper
passive front struts. .............geo
Thanks geo, I also have an ABS light that has been on since new rear brakes and rotors a year ago...........
 

·
Registered
Joined
·
162 Posts
gretzer said:
Thanks geo, I also have an ABS light that has been on since new rear brakes and rotors a year ago...........
GR....Do your ABS brakes work? If so Maybe they damaged
the ABS sensor and or wire. You have 4 wd disc right ?
Pull the tire off and check. Sometimes they let the caliper
hang by the hose or ABS wire and mess stuff up !

Or you can check the codes on yourself by using the heater
controls. Maybe even disconnecting the batttery will reset
the ABS code.
 

·
Registered
Joined
·
3 Posts
sonjaab said:
GR....Do your ABS brakes work? If so Maybe they damaged
the ABS sensor and or wire. You have 4 wd disc right ?
Pull the tire off and check. Sometimes they let the caliper
hang by the hose or ABS wire and mess stuff up !

Or you can check the codes on yourself by using the heater
controls. Maybe even disconnecting the batttery will reset
the ABS code.
Yes,4 wheel discs. As far as I know the abs brakes are working fine. Actually the rear brakes has been changed twice since the light came on the firstime and never went off. Took it back then to check for loose wie and they said they checked connections this time too. They tried disconnecting the battery and it's still on. [email protected]
 
1 - 6 of 6 Posts
About this Discussion
5 Replies
3 Participants
gretzer
Top