Cadillac Owners Forum banner

21 - 40 of 47 Posts

·
Registered
2007 CTS
Joined
·
1,572 Posts
IMO your alternator is gone! Alternators that are bad can still put out the prper voltage but not enough AMP's to run everything
 

·
Registered
2006 CTS-V
Joined
·
4,969 Posts
AHH Yess doing it again now the volts are going crazy low when driving down to as low as 9 volts,drove home pulled into garage shut it off and restarted fine then shut it off pulled the key out and tested the battery with multimeter and reading 11.78 I then started the car again and did not get any warning lights or messages and volts were 14.2 without radio,heater,headlights on then only dropped to 13.4 with all on.Do you think it is the ECM going bad should I pull the alternator and have it tested? Thanks
You should pull the alternator and have it replaced.

I had to search thru my phone for a video just now but:


If this is what you are getting (and as you can see, my battery voltage was 13.8), its alternator.
 

·
Registered
Cadillac CTS 2003
Joined
·
79 Posts
Discussion Starter #23
OK Thanks for the video thats whats it doing but started it this morning and all is good nothing on the display no warning battery light even with seats,radio,heat and headlights on it showed 14.2 volts.Should I just go to Autozone and have them check the battery and alternator?
 

·
Registered
2007 CTS
Joined
·
1,572 Posts
That would be a good start. However if your battery is failing a load test could drain it to where it wont start. Hopefully they have a jumper box to get you going again
 

·
Registered
Joined
·
4,193 Posts
OK Thanks for the video thats whats it doing but started it this morning and all is good nothing on the display no warning battery light even with seats,radio,heat and headlights on it showed 14.2 volts.Should I just go to Autozone and have them check the battery and alternator?
Have I got this right, the car performs perfectly, but this message pops up ?

I'll go along with the calls to rebuild the alternator, but if you don't mind getting stuck, or if you have one of those instant jumpstart devices they sell, you might just want to ride things out until the battery gets sluggish, which will happen if its really the alternator. Otherwise you just have an annoying messaage.

The battery symbol on the instrument panel is supposed to come on when the alternator output is lower than the drain on the battery.
You could have an intermittant short causing a temporary drain while you're driving.

There's no harm in having a free electrical test done, but I haven't found them to be very reliable.
 

·
Registered
2007 CTS
Joined
·
1,572 Posts
I di have an old chevy truck that the alternator would charge fine at idle but at highway speed it would stop charging. I tell you it was a pita. When I bought it I drove it from salt lake to Las Vegas at night. About every 30 miles I had to stop let it Idle a while to charge back up then I could go another 30 miles stop and let it charge again. I was the alternator. Luckily back then they had all night auto parts stores in Vegas. Bought a new alternator and never had a problem again.
 

·
Registered
Cadillac CTS 2003
Joined
·
79 Posts
Discussion Starter #27
Autozone tested the battery and alternator both checked out good they said to bring the car back next time it is acting crazy.I am just going to drive it I guess until I am stranded lol

----------

I am half tempted just to replace the alternator from "odthetruths" posting.

----------

When you got the dash read out did it just do it sometimes before you replaced the alternator?
 

·
Registered
2007 CTS
Joined
·
1,572 Posts
How did they check the alternator? Did they hook it up to a macine that tests it at idle and at high RPM? Ive seen some of those autozone guys just take out a volt meter and check yup, 13 volts it's good!
 

·
Registered
Cadillac CTS 2003
Joined
·
79 Posts
Discussion Starter #29
Just at idle

----------

I think I am just going to pull it tomorrow and replace it looks like it would be a lot easier to go from the bottom was thinking of jacking the car up removing the right front tire and wheel well plastic liner,anyone else have a good way to remove it?Thanks All, Love this Forum
 

·
Registered
Joined
·
4,193 Posts
Mickey, you might be spending money that you don't need too. There honestly was a massive solar flare a couple of weeks ago that triggered at least two problems. And ECM's go bad too often to count. For twenty dollars you can get a quick jump machine to keep in your trunk, it a miniature battery with clamps, light to carry and easy to use. I'd wait it out, the alternator is $157.25 online for the cheapest rebuilt one for 2003 at the first place I checked and $261.80 for remanufactured by OEM.
 

·
Registered
Cadillac CTS 2003
Joined
·
79 Posts
Discussion Starter #31

·
Registered
2004 3.6L v6 cts lux
Joined
·
869 Posts
looks like i might have to do the same. I'm gonna put in a HO alt in mine. I keep getting the flickering of lights when my bass hits or when i press the window button at night. Got the car pc with the 8 in touchscreen, 2 amps feeding off the battery which is being charged by the original alt at 98k miles. I think it's about that time. Denso has some pretty inexpensive 250amp ones on the web.
 

·
Registered
2004 3.6L v6 cts lux
Joined
·
869 Posts
Nope havent done it yet. Looks tempting from what I've researched just wish i had the time to spare with work & school(both full time) it's hectic.
 

·
Registered
Joined
·
4,193 Posts
Nope havent done it yet. Looks tempting from what I've researched just wish i had the time to spare with work & school(both full time) it's hectic.
Yeh, time, time, time. The only difficulty I've ever had was getting the case open. Sometimes they're sealed and you have to drill them out and replace the fasteners with fresh nuts and bolts. Once the case is open, I take sandpaper or emory cloth to the copper plate and get all the black residue from the brushes off, then polish it with wet or dry. Remove the remnants of the old brushes and pop in the new ones. Its simple, and it saves a bundle.
 

·
Registered
Cadillac CTS 2003
Joined
·
79 Posts
Discussion Starter #38
After driving for a week or so I do not have any problems volts are constantly over 14 when driving with seats,radio and headlights all on so pretty sure it must have been the alternator. When I returned the core to Autozone the machine was down to check it but they still gave me my $47 back so thanks to everyone for their input.
 

·
Registered
06 3.6L CTS w/sports package
Joined
·
115 Posts
Didnt want to create another thread, so I'll hijack this one...

My car didnt start yesterday, it wouldnt even crank as a matter of fact. After failed attemps of jump starting it, I just disconnected the battery and left as is overnight. My theft service lock (I think thats what its called) light came on, and I wasnt able to remove the key from the ignition. Tried again today to start it, but didnt work. Lights and everything work fine, my voltage from the radio reads 11.8 with the key in the "on" position. Can anybody chime in with how I can probably get this fixed? Im hoping its nothing major because I need the car tonight

----------

Forgot to add that I doubt that its the battery, being that I bought a brand new one a month ago
 
21 - 40 of 47 Posts
Top