Cadillac Owners Forum banner

1 - 7 of 7 Posts

·
Registered
2005 Cts-V
Joined
·
6 Posts
Discussion Starter #1
Hi Guys -- I love the site and all the info and help I've gotten from the forum.

I've searched and also checked out the FAQ and can't seem to find anything about the airbags. When I start my car the Service Airbag System shows up on my Nav screen and then the airbag light stays on in the dash. Rear view mirror says Airbag off even with someone in the passenger seat.

Do you guys have any ideas? Or do I have to take it to the dealer? Are any other shops able to diagnose this?

Any help or ideas would be great!
Thanks
Brian

2005 CTS-V
 

·
Registered
2005 CTS-V
Joined
·
784 Posts
I believe there is a sensor in the passenger seat that involves replacing the lower part of the passenger seat to fix it.

You still under warranty?
 

·
Registered
06 Stealth Grey CTS-V
Joined
·
78 Posts
Mine was in for that last month. I understand that there is a number of things that it could be, but you need a TECH 2 scanner to access the diagnostics.
Mine was the PPS,(Passenger Presence Sensor). They changed the seat bottom, under warranty.
 

·
Registered
2005 Cts-V
Joined
·
6 Posts
Discussion Starter #5
Just had my codes read by a local mechanic. It came up with the same sensor you are referring to... the passenger occupancy sensor. Dealer wants over $360 just for the part. Anyone have any new or used part sources where I might be able to find it cheaper?

Thanks in advance
Brian
 

·
Registered
2006 CTS-V
Joined
·
90 Posts
Wow, 360 for the part... that's crazy... Contact Luke at Lindsay Caddy and see if can do better than that.

BTW, I had the exact same problem but my car was under warranty so the dealer fixed it.

Good luck.
 

·
Registered
'05 ProCharged cts-V -Silver on Black
Joined
·
673 Posts
Wow, 360 for the part... that's crazy... Contact Luke at Lindsay Caddy and see if can do better than that.

BTW, I had the exact same problem but my car was under warranty so the dealer fixed it.

Good luck.

Had that sensor replaced at the dealer couple months ago. thought it would cost couple hundred. But "wow" it was outrageous, can't remember the exact amount cause I was trying to forget it. But total was something like $700 installed I think.

And for obvious reasons I'm not under warranty
 
1 - 7 of 7 Posts
Top