Cadillac Owners Forum banner

1 - 20 of 26 Posts

·
Registered
Joined
·
72 Posts
Discussion Starter #1
ok this is weird both of my passenger windows dont work but my driver side windows work. (no the window lock isnt on) when i hit the button i hear a clicking. i took the door panel off and the black control box is making the clicking. i unpluged the motor and used a test light on the harness and seems like there is power to all wires at the proper time i hit the button. Is it really possible i blew both motors? is there any power or something that could have shorted them out together and not the other side?? im stumped and Where the hell is the window fuse. Help would be GREATLY appreciated. Im willing to give someone a big FIVE DOLLARS via paypal if you can figure this out lol thanx
 

·
Premium Member
2006 STS V8 AWD, '95 Ford Ranger
Joined
·
28,974 Posts
What's the very last thing you did when the windows quit working? A good place to start is to disconnect the battery for a couple of minutes and then reconnect it. This will reboot most of the electronic stuff in your car.
 

·
Registered
Joined
·
4,422 Posts
What's the very last thing you did when the windows quit working? A good place to start is to disconnect the battery for a couple of minutes and then reconnect it. This will reboot most of the electronic stuff in your car.
Damnit Koz.....quit trying to move in on my double cheeseburgers.....I knew you would come around when the food got involved:want::want:

LOL....my parents where on an ALaskan cruise the last couple weeks and were just in Fairbanks...I told them if they see a red STS cruising around.....to leave a not that FlyFLip was going to steal it......Lucky for you they didnt find ya :D
 

·
Registered
Cadillac
Joined
·
164 Posts
There is a fuse for the passenger side door module in the fuse box under the rear seat on the passenger side box. But, it would be odd for it just to blow for no reason. I would think it would be more logical that you would have a door module problem, especially if it is clicking as you say. First try running a jumper power wire and a ground directly from the battery to window motor and just see if it will go up and down.
 

·
Premium Member
2006 STS V8 AWD, '95 Ford Ranger
Joined
·
28,974 Posts
Damnit Koz.....quit trying to move in on my double cheeseburgers.....I knew you would come around when the food got involved:want::want:

LOL....my parents where on an ALaskan cruise the last couple weeks and were just in Fairbanks...I told them if they see a red STS cruising around.....to leave a not that FlyFLip was going to steal it......Lucky for you they didnt find ya :D
They can steal all the red STS's they want; mine is Silver Smoke.
 

·
Registered
> BMUU
Joined
·
14,388 Posts
yo Mike r u trying to regain the 5 bucks u just paid for ur membership :lol:
 

·
Premium Member
2006 STS V8 AWD, '95 Ford Ranger
Joined
·
28,974 Posts
AWD is a bummer. No burnouts. All you can do is leave everybody else in your dust. If you try a drop start you about snap your head off.
 

·
Registered
2007 Cadillac CTS 3.6L Black, LOADED
Joined
·
2,424 Posts
There is a fuse for the passenger side door module in the fuse box under the rear seat on the passenger side box. But, it would be odd for it just to blow for no reason. I would think it would be more logical that you would have a door module problem, especially if it is clicking as you say. First try running a jumper power wire and a ground directly from the battery to window motor and just see if it will go up and down.
Although I agree it is very weird for fuses to blow for no reason, it does happen. I bought a new ATV in 1999. It was a 2000 Suzuki Quadmaster 500, sick ATV for its time. Any way... about a week after I bought it the temp light came on while driving it. I shut down the engine right away. Brought it to the dealer and they informed me it was the fuse for the radiator fan that blew out. They replaced the fuse and AGAIN it blew out a few weeks later. I then replaced the fuse myself. Never had to change it again and it been fine for the past 7 years. (Yes I replaced it with the correct amperage fuse.)
 
1 - 20 of 26 Posts
Top