Cadillac Owners Forum banner

1 - 6 of 6 Posts

·
Registered
2001 DTS / 1973 fleetwood
Joined
·
281 Posts
Discussion Starter #1
who owns and drives a '00 - '05 DEVILLE regularly and does NOT have the engine light on!

I've owned an '01 DTS for about 5 yrs, and everyday of its life, starting about a week after I bought it, its had its 'sevice engine' light on..

I know everything it needs, and likely about 2K to fix all the issues, but funny, not one of those fixes interfere with day to day driving...

my opinion, the biggest bain to this Gen of deville is the oversensitive engine light

i like the marque where 'service stability system' scrolls across..THEN goes AWAY, but the engine light should be reserved for '10 minutes before melt down'..imo

that is all !
 

·
Registered
85 Coupe Deville 4.1 V8 & 4.3 V6 Deisel & 1970 Eldorado
Joined
·
773 Posts
I believe the law requires that the service engine lamp show any time that a failure is detected that could effect the emission control system. Anyone please correct me if i am wrong.
 

·
Registered
2020 XT4, 70 Cougar conv, 2002 DTS
Joined
·
899 Posts
I believe the law requires that the service engine lamp show any time that a failure is detected that could effect the emission control system.
That's correct.

To the OP: what DTCs do you have that are causing the light? I've got a 02 DTS & SES is rare & when it does come on the DTCs point to something specific that can be addressed. In every case, there has been something real that was wrong, not an overly sensitive SES.
 

·
Registered
08 STS4 V8 1SG & 04 SRX4 V8 & 01 Monte SS
Joined
·
5,022 Posts
I have driven one (2002 DTS) daily for the last two years or so and no the service engine light is never on. Even when I had a service stability system message (needed a steering wheel position sensor) it didn't come on. I think that you should just fix the issues with the car especially after having it for 5 years with only 2k of repairs needed it's not that much to take care of.


Sent from my unlocked jailbroken iPhone 4 iOS 4.2.1
 

·
Registered
No more Cadillacs
Joined
·
680 Posts
We have 3 Devilles in our house, 2 2001's and 1 2002. On my 2001, about every 3 or 4 months I get the light with the 0741 code for the TC clutch. Always resets and I dont see it again for months. On the other 2 Devilles, I've only had the light when the intake plenums started leaking pretty bad. Once I replaced them, that was it. Oh, occaisionally it lights on my son's 2001 Deville for the evap system (tank pressure I believe), but then it disappears for a few months also. To me, it is a rare situation when the light comes on. I bought my 2001 about a year and a half ago. It would not pass emissions in the county the owner resided in. The light was on solid for over a year. The owner sunk alot of money in it and no one could seem to fix it. Needless to say, I got the car for a great price. Ended up repairing a broken wire on the evap solenoid,replacing the intake plenum and the IAC. Persistance pays of with these cars. If you cannot fix it yourself, you need to find a good mechanic thats honest.
 

·
Registered
2015 XTS AWD - Black inside and out
Joined
·
286 Posts
2003 DTS had for 3 years and did not have the engine light at all up until last week. I had the Service Stability Sys come on with the ABS and engine light. i cleared codes and am waiting for it to come on again to check the codes. One history code said the right rear speed sensor is bad. We will see. I have spent about $2000.00 in 3 years on tires, brakes and a crossover/plenum gasket repair.
Pretty usual maintenance I think.
 
1 - 6 of 6 Posts
Top