Cadillac Owners Forum banner

1 - 17 of 17 Posts

·
Banned
2005 STS4 1SG: GM Acc Lights, Corsa, Platnium Grille, Volant
Joined
·
15,987 Posts
Discussion Starter #1
Ok so ive done my HW
ive read that just about everytime it goes its the element not the module.
Well heres the thing
I turn my car on and the 1st time i hit the button, i hear the click, however then if i push the button from low then to off it doesnt click indicating its now shut off. If i leave it on, it continues to click every so often. If i try putting it on a second time i get no click sounds what so ever.
Wouldnt that mean my module is bad? Especailly since ive read that there are two independent elements, one for the back, and one for the bottom and since, both arent working, wouldnt that also go to show its actually the module?
Thanks alot guys!
 

·
Super Moderator
White Diamond '03 DHS (with DTS floor shift)
Joined
·
86,969 Posts
I am not positive, but I believe if one element goes out, the other will loose current and thus become inoperative.
 

·
Banned
2005 STS4 1SG: GM Acc Lights, Corsa, Platnium Grille, Volant
Joined
·
15,987 Posts
Discussion Starter #3
thanx
but even with the elements out the relay should still click on and off correct?
as i said it will click the very 1st time on and then never click again until i turn it off and wait a few minutes
 

·
Banned
2005 STS4 1SG: GM Acc Lights, Corsa, Platnium Grille, Volant
Joined
·
15,987 Posts
Discussion Starter #6
thats my point
it clicks once only when it comes on not again when it goes from low to off the pass side which works does and same with my dads 98 STS
 

·
Registered
2013 XTS
Joined
·
2,087 Posts
Mine was a constant click on my bad one in my 99 and I replaced the module and that didn't fix it.
I am going to say the element is the culprit here. I have the old element laying around if you want it ? i think it's still good.
 

·
Banned
2005 STS4 1SG: GM Acc Lights, Corsa, Platnium Grille, Volant
Joined
·
15,987 Posts
Discussion Starter #9
Mine was a constant click on my bad one in my 99 and I replaced the module and that didn't fix it.
I am going to say the element is the culprit here. I have the old element laying around if you want it ? i think it's still good.
yea why not man
get back at me
much appreciated
 

·
Registered
Cadillac
Joined
·
47 Posts
my drivers side heated seat aint working no more.

I do hear clicks... but no warmth.

I'll pay attention to when it clicks... but it does.

So what should i do to get this fixed?
 

·
Registered
Cadillac
Joined
·
47 Posts
My driver side heated seat worked like... 1 month ago... it JUST stopped.

It's clicking... i don't know when... but i do hear a click... i'll pay more attention.

What's the easiest way to diagnose this problem? Also... if it's the element... can i change that?
 

·
Super Moderator
White Diamond '03 DHS (with DTS floor shift)
Joined
·
86,969 Posts
Yes, the element is replaceable. I think someone once posted the procedure with pictures.
 

·
Registered
Joined
·
14 Posts
Hi.. My driver seat clicks on ..then warms up and starts clicking back and forth until i just shut it off.. it does a steady click very fast like a blinker... Passenger side works fine.... Would that be the element?? Thanks in advance.
 

·
Registered
Joined
·
42 Posts
I got the factory trouble shooting thing and am kinda smart, but I can't tell which block is which under the seat. I was hoping that someone could direct me to wire or block colors... there is a green one under there. Any trick's or hints about removing the seat covers? Both the front seats on my 2000 StS are cold... kids loving those back seat toasters!!! I guess it is revenge from Mom and Dad having seat heaters in the Toyota and none for the kids.
Thanks...
 
1 - 17 of 17 Posts
Top