Cadillac Owners Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
92 Posts
Discussion Starter #1
I know that these codes translate as follows:

RSS C1743 Speed Signal Fault
RSS C1783 - ICCS2 DL Left Output Short Circuit to GND
RSS C1785 - ICCS2 DL Right Output Short Circuit to GND

My "service ride control" is on too. I know the RSS is Road Sensing Suspension, and the C is "current". Can anyone tell me more about this or how to fix this problem? Front or rear? Could this short be at fault for draining my battery at times making it difficult to start the car?

Thank you, -Adam
 

·
Registered
Joined
·
5 Posts
miishmiish said:
I know that these codes translate as follows:

RSS C1743 Speed Signal Fault
RSS C1783 - ICCS2 DL Left Output Short Circuit to GND
RSS C1785 - ICCS2 DL Right Output Short Circuit to GND

My "service ride control" is on too. I know the RSS is Road Sensing Suspension, and the C is "current". Can anyone tell me more about this or how to fix this problem? Front or rear? Could this short be at fault for draining my battery at times making it difficult to start the car?

Thank you, -Adam
Hi. You have to check the connectors at each wheel sensor and check wire harness for shorts. It may be a dual problem. That's why it's hard to start. Check the harnesses between the valve cover and the fire wall. The wheel sensors produce very low voltage. Good luck.

P.S. You could check the web. Just type in "Cadillac Wheel Sensors" and it should pull some very helpful information.

Tom
 

·
Registered
Joined
·
92 Posts
Discussion Starter #3
officerom said:
Hi. You have to check the connectors at each wheel sensor and check wire harness for shorts. It may be a dual problem. That's why it's hard to start. Check the harnesses between the valve cover and the fire wall. The wheel sensors produce very low voltage. Good luck.

P.S. You could check the web. Just type in "Cadillac Wheel Sensors" and it should pull some very helpful information.

Tom
Thanks for the response. I get the general idea, but could you be more specific? I don't know where to look for the sensors or what a short looks like (or a valve cover and fire wall). Do you know from the codes which wheels to look behind?

Thank you
-Adam
 

·
Registered
Joined
·
92 Posts
Discussion Starter #4
RE:1997 Concours

Is the correct sensor located under the hood right on top of the strut?
Also, could some blown fuses be the cause for this?
And last, where in the trunk are the fuses? The rss fuses are not in the engine compartment.

Thanks for any replies.
 

·
Registered
Joined
·
397 Posts
miishmiish said:
RE:1997 Concours

Is the correct sensor located under the hood right on top of the strut?
Also, could some blown fuses be the cause for this?
And last, where in the trunk are the fuses? The rss fuses are not in the engine compartment.

Thanks for any replies.
You said that you're getting 'Shorted' codes. Fuses will not cause 'short' signals they cause 'open' signals. I highly doubt it's the fuses.
 
1 - 5 of 5 Posts
About this Discussion
4 Replies
3 Participants
2dfx
Top