Cadillac Owners Forum banner

1 - 6 of 6 Posts

·
Registered
94' Fleetwood, 95 RT/10 Viper, 2006 Honda XR650L.
Joined
·
294 Posts
Discussion Starter #1
Its not bad, but my car sometimes has a slighty rough idle, ONLY IN PARK.

in drive, at a light, it has zero shake.

Anyone have any ideas?

how hard are plugs and wires to do on the LT1?
 

·
Registered
1985 Cadillac Fleetwood Brougham d'elegance - 1969 Coupe DV (R.I.P.)
Joined
·
655 Posts
check for a vaccum leak. take off the air filter with the car running in park and spray carb cleaner all around the base of the intake manifold. if that doesnt help, let me know cause i have a few other tricks in mind. my truck had the same problem and this cleared it right up.
 

·
Auto Enthusiast
1992 Eldorado Touring
Joined
·
3,688 Posts
Plugs and wires are easy to do on the driver's side... a pain on the passenger side.

It could be many things, from a air leak to optispark... hard to diagnose, is it throwing any codes?
 

·
Registered
'93 Fleetwood Brougham...Dad's
Joined
·
4,382 Posts
check for a vaccum leak. take off the air filter with the car running in park and spray carb cleaner all around the base of the intake manifold. if that doesnt help, let me know cause i have a few other tricks in mind. my truck had the same problem and this cleared it right up.
Uh, NO, NOT a good (or even valid) idea with a fuel injected car--an LT1 is a lot different than any old 80's carb wonder.

That said, the LT1 seems very sensitive to any ignition irregularities and there can be a lot of random misses from one time to another, from any variety of sources.

Yours, though, is ODD, that you only seem to notice it sitting in park. Since it seems fine when in gear, it could be almost anything. Actually, just off the top of my head and something I'm reading right now, maybe try a good cleaning of the throttle body and IAC (Idle Air Control), which might be gummy or something only when the sitting in idle mode:

http://impalassforum.com/noncgi/ultimatebb.php?ubb=get_topic;f=33;t=012568#000000
http://impalassforum.com/cgi-bin/ultimatebb.cgi?ubb=get_topic;f=33;t=012195#000003

and others (just need to search, as I used "rough idle"):
http://impalassforum.com/cgi-bin/ultimatebb.cgi?ubb=search;search_forum=33
 

·
Registered
94' Fleetwood, 95 RT/10 Viper, 2006 Honda XR650L.
Joined
·
294 Posts
Discussion Starter #6
Thanks for the tips guys, 96fleet...no codes, well the cel is not on at least, I will go into diagnostics to check that.

I will do some reading on the links, thanks.

What ever it is does not seem to effect mileage as I got 29 the other day, does that help at all?

Does the over the counter injector type stuff work? what about sea foam?
 
1 - 6 of 6 Posts
Top