Cadillac Owners Forum banner

1 - 20 of 58 Posts

·
Banned
2005 STS4 1SG: GM Acc Lights, Corsa, Platnium Grille, Volant
Joined
·
15,987 Posts
Discussion Starter #1
So my ETC recently has devloped a rough idle at start up, if you give it gas for about 10-15 sec it clears right up. Its not plugs ive replaced them along with wires with a/c delco platniums. I dont THINK its the HG, it doesnt overheat, and theres only a small loss of coolant which i think is from the top hose, it has dex on it. To be safe today i added some Blue Devil, coolant sealer (if it is HG b.c is so minor im hoping this will solve it yuh i know its not likely) and on the way home it DID overheat but that was b.c it was low on coolant b.c the Blue Devil has you remove the thermostat and run the car for a bit before replaceing the thermostat. Anywho any other ideas on what else it could be causing this? I mean i doubt its the coils but ill replace them too if thats what others think it is. Thanks alot guys!
 

·
Super Moderator
White Diamond '03 DHS (with DTS floor shift)
Joined
·
86,996 Posts
:tisk:
To be safe today i added some Blue Devil, coolant sealer
Use only the tabs supplied from the dealer or Barsleaks sealant tabs (same thing).

See if your FPR is leaking.
 

·
Banned
2005 STS4 1SG: GM Acc Lights, Corsa, Platnium Grille, Volant
Joined
·
15,987 Posts
Discussion Starter #3
idiot moment
how should i check that the FPR that is, if its not that then am i looking at HGS, anything else i should check as well?

and i told my boss (at the car shop i work at every morning) that i should use the barsleak, he said thats crap and this 50 dollar blue devil crap is the best there is, so i took his word for it.
 

·
Super Moderator
White Diamond '03 DHS (with DTS floor shift)
Joined
·
86,996 Posts
With the engine at idle, pull the vacuum line off of the FPR (on the fuel rail). If fuel leaks out of the nipple, the FPR is bad. If that is OK, it could be an injector leaking down. Tech Tips section has a thread on how to check them.

Nothing in a bottle is going to fix a blown head gasket, but it is to early to suspect that.
 

·
Banned
2005 STS4 1SG: GM Acc Lights, Corsa, Platnium Grille, Volant
Joined
·
15,987 Posts
Discussion Starter #5
he also had me pull the plugs
all of them except one were fairly brown at the white end (not the platinum tip but the white end after the screw) the other was VERY white.
 

·
Administrator
2002.5 F55 CORSA STS, 2014 Explorer XLT FWD
Joined
·
69,132 Posts
:confused: One VERY WHITE plug tip sounds like lean mixture to me. Pull the injector and take it to a shop for cleaning...cheaper than a new one, or score 1 off EBay. If one cylinder runs lean, it's entirely possible that it acts like there's no "choke" on until the cylinder gains enough heat to assist firing the lean mixture. Just a guess.
 

·
Banned
2005 STS4 1SG: GM Acc Lights, Corsa, Platnium Grille, Volant
Joined
·
15,987 Posts
Discussion Starter #9
im thinking an injector too
at start up this time i went behind and smelt the exhaust
and it smelt like raw fuel
 

·
Super Moderator
White Diamond '03 DHS (with DTS floor shift)
Joined
·
86,996 Posts
Have you checked the FPR? Or leaky injector? How about a vacuum leak?
 

·
Banned
2005 STS4 1SG: GM Acc Lights, Corsa, Platnium Grille, Volant
Joined
·
15,987 Posts
Discussion Starter #13
checked FPR was dry
fuel rail looked like a bia to get into with only an hr left so i decided to get into that tomorrow
and i doubt a vacuum leak, no codes, no issues after 10-30 secs of running, and no sucking sound like a vac is off...
 

·
Super Moderator
White Diamond '03 DHS (with DTS floor shift)
Joined
·
86,996 Posts
Is your coolant level holding steady or is it going down (being consumed)?
 

·
Banned
2005 STS4 1SG: GM Acc Lights, Corsa, Platnium Grille, Volant
Joined
·
15,987 Posts
Discussion Starter #17
hard to tell, i just reinstalled the thermostat today *the blue devil stuff i added told me to run it without it for a day* so coolant was lost and then readded... ill know better tomorrow but i dont think so, there was a small amount loss about one a mth id have to add a gallon of mixed coolant to it, but it had to be leaking from a hose because there was a small puddle in the morning, hence why i tightened the upper rad hose which had some dex on it.
 

·
Registered
90 Eldo -SOLD-, 98 ETC -SOLD-, 86 XR4Ti Track Car, 07 Ranger
Joined
·
963 Posts
My ETC had a small coolant loss, continuously but first the waterpump, then radiator, then hoses went and finally the whole problem came back to the HGs, I was seeping just enough coolant into the front bank to foul the spark on a cold start but once it warmed up and sealed everything was fine.....
 

·
Registered
White Diamond 2001 STS
Joined
·
1,317 Posts
Don't jump to conclusions. Wait a week and see if the coolant level holds steady, and go from there. Go to your dealer and have them print out a repair summary for your vehicle and look for anything out of the ordinary. It's amazing what you'll find on those things sometimes.
 
1 - 20 of 58 Posts
Top