Cadillac Owners Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I have a 97 Seville, have had it since 99, where both keyless entry fobs have been deemed to be bad by the local Cadillac dealer. I have found some comparable RKE's on the web, but I need to know if anyone knows how to reprogram them to sync up to my car. I tried the procedure on the following website, to see if the car would go into the sync mode, http://myweb.accessus.net/~090/cad96rke.html
but the first instruction where you get into the diagnostics by the following procedure:
"Press OFF and WARMER (or the OFF and PASSENGER WARMER buttons) on climate control panel simultaneously Instrument Panel Cluster (IPC) will light all telltales, then go blank. System is now in DIAGNOSTIC MODE" will not work on my car. Does anyone know what the correct procedure is, or can give any help? Thanks.
 

·
Registered
None
Joined
·
49 Posts
Afternoon Jim,

You might not like my answer but I just had to get a new RKE and Key for my '02 SLS and you know how I programmed it? I took it to my local Pensacola Cadillac Dealership, had coffee, surfed the net, and one hour later everything was perfect and my total bill for the Genuine GM RKE, Key, and Programming, was $110.

If you read all of the other threads on this forum for the exact same issue you get the gut feeling that you should just go ahead and do the Dealership and be done with it. This Dealership has never done anything to my car because I do all of my own maintenance except for Security with the Pass III Transponder equipped key.

Good Luck with what ever you choose to do....

Never Give up, Never Surrender

JP:horse:

 

·
Registered
2008 SRX-V8, 1991 Eldorado
Joined
·
1,543 Posts
I used that site for information to program new fobs for my 92 Eldorado. The information was completely wrong. I ended up consulting my FSM which had the correct procedure (of course).

For mine, The (FSM) procedure was to short the black wire on the harness going to the trunk pull-down motor and follow three simple steps. The procedure from the referenced web site above advised to short two ALDL pins. The pins "they" specified were not used (empty) on the 1992 Eldorado.
 

·
Registered
1997 DeVille Councours
Joined
·
11 Posts
Thanks folks!

You've just brought my #1 fob back to life and saved me $80 (the cost of two new fobs from ebay).

The posting from jimmerheck tipped me off to the website (http://myweb.accessus.net/~090/cad96rke.html) that includes the following instructions: "If they're still not working (after installing fresh batteries) and you feel like messing around with it a little, take the key fob totally apart and clean the contact points behind the rubber membrane and the brass etchings on printed-circuit (PC) board - this may be just enough to bring it back to life! Moisture intrusion and the resulting corrosion on the contacts is usually the culprit in a lot of "not working" situations."

In my case, taking the fob apart and close examination showed that one of the leads of the flat, gray colored capacitor close to the keyhole had broken loose from the circuit board. A quick touch of the soldering iron brought her back to life.

Thanks!

Rick Russell

Now if I could just find as simple and inexpensive solution to the fact that my gas guage goes haywire when the needle gets to "half full"!
 

·
Registered
Joined
·
12 Posts
Funny you should mention this about the gas gauge. Our 97 STS is having the same problem and others as well.
The tank reads about below half and then resets itself to somewhere about 3/4. Tonight my wife calls me to say it is having other brain farts. The clock keeps resetting, I was driving the other day and it just died. Restarted just fine, but what the heck.
I also could not use the method of diagnostics to reset my key fobs.
I really do need to get after these things, but I could use some help!:confused:
 

·
Registered
2002 STS, 2005 CTS 3.6
Joined
·
413 Posts
This step should be modified as I tried to program my remote several times with no luck.

"5. Press and hold TRUNK button on the transmitter. While holding TRUNK button, press LOCK button and hold both buttons for a total of 3 seconds. Locks will cycle when programming is complete. If transmitter is not programmed within 30 seconds after entering "99" on the display, system will default and you must begin at step #2 again."

I tried to program mine several times with no luck. You need to push and hold the trunk button and then IMMEDIATELY push the lock button and hold them for about 3 seconds until the locks cycle. If you wait more than a second or two to push the lock button, it will not program.
 
1 - 7 of 7 Posts
Top