Cadillac Owners Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hello all... Im new to the site and I need your help. I have a 2006 cts 2.8L. Last week it was skipping and the CEL was blinking. We the CEL light finally stayed on so I went and got it checked. I had
random misfires and misfires on all 6 cylinders. :mad2: I replaced all spark plugs and replaced all coil packs. The car runs great but the CEL is still on. I went back and got the CEL checked again and now it
brings up codes P0351 – P0356 Ignition Coil A-F Primary , Secondary Circuit Malfunction.:want: I purchased aftermarket coils and NGK plugs. Does it mater what coils I used.:confused::confused: Please help me on this someone. How can I get the CEL off and codes cleared.:confused: Thanks in advance for your answers. :worship:
 

·
Registered
CTS
Joined
·
35 Posts
First off, 6 coils don't go bad at one time. They usually drop out one, maybe 2 at a time. So that leaves you with bad wiring or bad PCM. Here's a link to OBD Codes. http://www.obd-codes.com/p0351.
Seeing how it's all 6 that are misfiring, I think I would start with the wiring from the PCM and move forward toward the individual Coils.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Does it matter what type of coils I bought because I went with some cheap no name brand coils. I had the company refund me my money and I was gonna go with some ac delco just to see if they made a difference. Also I forgot to mention I had my oil changed that day and it was real low. I only had like 2 quarts of oil in it. It did not show any signs of oil leaking, but I heard Cadillac was bad for losing oil. I run synthetic and I ran it 5000 miles. I wont do that again but I thought it would last. I will do it every 3000 miles like I do the rest of my cars. Also when I removed my coils and plugs I had oil on the threads of the plugs. Whats would be the cause of that? Does 06 cts have rough idling cause mine does also? I know this is alot of questions but I'm just trying to figure this out cause I love my CTS. Thanks for the help I will keep you posted when I change the new coils. Last questions what is PCM? Do you have any answers to what I just stated if so please help me out on this one cause I am stumped.
 

·
Registered
2005 CTS/ 2008 DTS/ 2008 STS V8 N*/ 2011 CTS4 ALL W/D Pearl
Joined
·
688 Posts
Does it matter what type of coils I bought because I went with some cheap no name brand coils. I had the company refund me my money and I was gonna go with some ac delco just to see if they made a difference. Also I forgot to mention I had my oil changed that day and it was real low. I only had like 2 quarts of oil in it. It did not show any signs of oil leaking, but I heard Cadillac was bad for losing oil. I run synthetic and I ran it 5000 miles. I wont do that again but I thought it would last. I will do it every 3000 miles like I do the rest of my cars. Also when I removed my coils and plugs I had oil on the threads of the plugs. Whats would be the cause of that? Does 06 cts have rough idling cause mine does also? I know this is alot of questions but I'm just trying to figure this out cause I love my CTS. Thanks for the help I will keep you posted when I change the new coils. Last questions what is PCM? Do you have any answers to what I just stated if so please help me out on this one cause I am stumped.
Have someone start the car while you stand in front of it with the hood opened and try to listen at the front of the engine (pulleys and belts) for any kind of start up rattle from the timing chain.

If you do hear it see if it continues while it idles, if it does not continue and only happens at cold start or not at all you are probably ok just fixing the miss problem with coils and plugs. Full oil is essential in this engine.

Sometimes we can leave the power brake booster hose off when we change plugs this can cause a terrible idle.
 

·
Registered
Joined
·
49 Posts
Hi
I am having the same issue "went back and got the CEL checked again and now it
brings up codes P0351 – P0356 Ignition Coil A-F Primary , Secondary Circuit Malfunction. I purchased aftermarket coils and iridium plugs." DID YOU EVER SWAP OUT THE COILS??
thanks
todd
 

·
Registered
Joined
·
38 Posts
I have this issue. Car runs perfect but throwing all these codes after new plugs and coils. Aftermarket coils from eBay. Just codes it runs so derfully
 

·
Registered
2007 CTS 3.6 >129k miles
Joined
·
499 Posts
Try putting original coils back on and trying again. Or known good coils from another car, if available. This will test whether the aftermarket coils are the problem.
 
1 - 7 of 7 Posts
Top