Cadillac Owners Forum banner

1 - 2 of 2 Posts

·
Registered
1999 Seville SLS
Joined
·
2 Posts
Discussion Starter #1
Hello fellow Caddy owners. I seek some help on a matter. Safelight replaced a rear windshield for me a couple months ago after my windshield exploded (suspect the defroster stayed on too long on a VERY cold day). Normally, I would have to restart the defroster to finish defrosting. This particular day I didn't notice it shut off, but the window wasn't finished defrosting before the windshield exploded into tiny little fragments which stayed intact (didn't fall into the car). My question is this. The new windshield comes with a double connector while my car has only a single connector. I am assuming that my single connector is for the defroster while the other slot would be for an antenna or something else. The window tech from Safelight plugged the single connector into one of the slots. Are these slots different in any way or are they the same design so it's possible connector was inserted in the wrong slot? The defroster still doesn't work, even though the defrost "light" comes on when I press the defrost button. Thanks for your help.
 

·
Registered
2001 Seville STS, 1990 Seville (RIP), 1972 Sedan Deville
Joined
·
26,323 Posts
Your rear glass has both a defroster and antenna in it, there are 3 separate connectors. One on each side of the glass (behind the sail panel/C pillar trim), and another at the very top of the upper grid, offset to the left. The ones at the sides are the ones for the defroster.
 
1 - 2 of 2 Posts
Top