Cadillac Owners Forum banner

1 - 20 of 55 Posts

·
Registered
Cadillac
Joined
·
162 Posts
Discussion Starter #1
Have had the esv loaded down last few weeks and I feel like the rear is riding a little lower. Do all esv have the rear air bags? It’s a platinum model. Or how can I tell. It rides great just looks a little low in back. Might be me just being paranoid.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
519 Posts
I thought the Platinum level all had Z95 Magnaride Self-leveling systems.

Do you hear the compressor run after start? Is it possible someone before you removed the system? How long have you owned it and how many miles?

The system is expensive if you have your vehicle maintained at the stealership. However, it can be fixed a reasonable cost if you can turn a wrench and don't mind a little dirt.

Sent from my Pixel 3 XL using Tapatalk
 

·
Registered
2012 Escalade ESV AWD Platinum
Joined
·
18 Posts
Take a pic of the sticker in your glovebox, it shows all the RPO codes for your Escalade. Look for Z95 or Z55 for suspension codes
 

·
Registered
Cadillac
Joined
·
162 Posts
Discussion Starter #5
Z95-so does that mean there is no compressor and it is all Magnetic?


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
519 Posts
Nope. That means you have both (as long as someone else didn't remove or modify the system before you).

If you don't hear the compressor at startup, I'd start troubleshooting there.

Sent from my Pixel 3 XL using Tapatalk
 

·
Registered
Cadillac
Joined
·
162 Posts
Discussion Starter #7
Start with a fuse? I can’t say that I have heard it start in a long time.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
519 Posts
Could be a fuse. That would be the simple approach. I believe there is a fuse and a relay under the hood that could be checked but my money is on the pump itself.



Sent from my Pixel 3 XL using Tapatalk
 

·
Registered
Cadillac
Joined
·
162 Posts
Discussion Starter #9
Where is the pump located? Do we have a part number for it?


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
519 Posts
Where is the pump located? Do we have a part number for it?


Sent from my iPhone using Tapatalk
It's on the left side behind the rear wheel. You'll see what looks like a box with some wires and small hoses running out of it.


Sent from my Pixel 3 XL using Tapatalk
 

·
Registered
Cadillac
Joined
·
162 Posts
Discussion Starter #11
What do I need to test? What wires? Car on? The swap out seems fairly simple.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
32 Posts
Have access to anything heavy? Like a trailer?

  • Hook up the trailer
  • Turn on your Escalade
  • Listen for the compressor to start
If it doesn't, it could be electrical or the compressor could be dead.

I just replaced my compressor with the Dorman 949-099 Compressor and it works awesome, way quieter than the last one too.
 

·
Registered
Joined
·
519 Posts
Mine runs everytime I start the engine for a few seconds. If you don't hear it I'd start in the fuse box. Check the fuse first. If it's good I'd just swap the pump and see what happens.

Sent from my Pixel 3 XL using Tapatalk
 

·
Registered
Joined
·
108 Posts
While ur down there u should inspect ur shocks as well check on the rubber see how bad there dry rotted I did that mine when I got mine they look bad but still hold air just waiting for the service suspension soon to come on


Sent from my iPhone using Tapatalk
 

·
Registered
Cadillac
Joined
·
162 Posts
Discussion Starter #15
Checked fuse it’s good. Will take a picture of underneath soon. More than likely the pump. As I do t recall ever hearing it. I figured if the pump was bad the back would really sag


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
519 Posts
The pump just levels the ride under load. It would ride low if you had a load in there or on the back. If it's just a couple of people you probably wouldn't notice much.

Sent from my Pixel 3 XL using Tapatalk
 

·
Registered
Cadillac
Joined
·
162 Posts
Discussion Starter #17
It seemed a little low when we went to az 5 people topped and back full!!!




Sent from my iPhone using Tapatalk
 

·
Registered
Cadillac
Joined
·
162 Posts
Discussion Starter #19
When i had it loaded up it got me thinking! That’s what prompted the question. So fuse is good. Is the next step to just order a new pump and put it in?

Can a shade tree mechanic do it or should a professional do it?


Sent from my iPad using Tapatalk
 

·
Registered
Joined
·
108 Posts
It not hard should take like forty minutes from videos that I’ve seen but that is my opinion


Sent from my iPhone using Tapatalk
 
1 - 20 of 55 Posts
Top