Cadillac Owners Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
Been a while since I posted, so this what I need help with.
P 0560 system voltage
P 1376 ignition ground
P 1520 gear indicator sys
P 1620 knock sensor
P 1644 torque control delivered torque output .
No tcs data
No sdm data
P1602 is the only current code. All the other only show history. I have a fresh optima yellow top battery. Today I replaced the ignition cylinder and clock spring and also the knock sensor. After half hr driving codes come back all history except p1602 knock sensor which is new. Car runs great by the way but I gotta take the emission test asap. Thanks for your help.
 

·
Registered
Joined
·
7,345 Posts
Been a while since I posted, so this what I need help with.
P 0560 system voltage
P 1376 ignition ground
P 1520 gear indicator sys
P 1620 knock sensor
P 1644 torque control delivered torque output .
No tcs data
No sdm data
P1602 is the only current code. All the other only show history. I have a fresh optima yellow top battery. Today I replaced the ignition cylinder and clock spring and also the knock sensor. After half hr driving codes come back all history except p1602 knock sensor which is new. Car runs great by the way but I gotta take the emission test asap. Thanks for your help.
Did you check wiring under the manifold as its a preferred spot for rodents to nest and chew.
The no data is concerning... It didn't say no codes?
If no data it means it can't communicate with that device. Is airbag light on also?
98 ground should be behind the ICM, easily left off.
There are a bunch of grounds on car, a couple hard to see or get to. I can't remember what issues were when a ground behind the engine (above trans) was bad for a member here but it was a bunch of stuff. Its a strange connection with spade terminals IIRC.
 

·
Master of the Dark Art of Diagnostics
Joined
·
18,818 Posts
Been a while since I posted, so this what I need help with.
P 0560 system voltage
P 1376 ignition ground
P 1520 gear indicator sys
P 1620 knock sensor
P 1644 torque control delivered torque output .
No tcs data
No sdm data
P1602 is the only current code. All the other only show history. I have a fresh optima yellow top battery. Today I replaced the ignition cylinder and clock spring and also the knock sensor. After half hr driving codes come back all history except p1602 knock sensor which is new. Car runs great by the way but I gotta take the emission test asap. Thanks for your help.
==========================
to me it looks like a loose/dirty/corroded ground or plug -
 

·
Registered
Joined
·
7 Posts
Discussion Starter #5
So far the the no tcs data was due to a loose connection at the motor. The no admin data I’m clueless on and yes the airbag light is on. As far as the ground I’ve been chasing that around for a while. I’ll check all the connections for corrosion next.
 
1 - 5 of 5 Posts
Top