Cadillac Owners Forum banner

1 - 6 of 6 Posts

·
Registered
1989 Seville STS C&C Build
Joined
·
90 Posts
Discussion Starter #1 (Edited)
Over the last week or so I noticed that the 89 sts was having trouble starting quite a few times would try it and nothing battery was fine so I assumed my starter was finally failing completely (I didn't hear any click from the starter when the key was turned). Over the last 6 months or so if the vehicle was driven for more than 30 minutes it would refuse to start unless it had cooled down (heat soak I was assuming because after 30 minutes to an hour all was well) So this weekend I went thru the painful job of replacing the starter with a new A/C Delco unit. (including removing the front half of the y-pipe that runs under the front of the motor:thepan:.)

Now comes my problem: The vehicle will still not start on occasions / with the turn of the key. One turn it may start perfectly fine the next I may just hear the starter click once and nothing else. however if I pull the key or even leave the key in the ignition it may or may not start on the next attempt. But in the end it will start on one of the tries and it may start several times in a row before it simply clicks.

I'm wondering if this could be a vats issue, ignition circuit issue, or something else entirely the wiring is all still factory, the battery is 13 months old the alternator was changed last fall and now the starter. This is a new issue that seems unrelated to the old heatsoak problem. I'm just not sure if this this was the exact same issue just before the starter was replaced i.e. this past week. ( I didn't do enough diagnosis)

Any help is greatly appreciated. on a side note I did have the battery tested today it checked out fine and the starting voltage shows over 12 and with the vehicle running it shows 14 volts so the alternator is working correctly.

Also getting to the starter connections now is extremely difficult with everything back in place.
 

·
Registered
98 DeVille, 97 DeVille d'Elegance
Joined
·
7,345 Posts
Highly doubt it's a VATS issue. It will not attempt to start when it is.
More than likely you have an issue with battery(have it load tested not just check volts), a cable connection issue or a bad cable. If it has a starter relay may want to pull it and check for corrosion also and even swap it out.
 

·
Registered
1989 Seville STS C&C Build
Joined
·
90 Posts
Discussion Starter #3
Highly doubt it's a VATS issue. It will not attempt to start when it is.
More than likely you have an issue with battery(have it load tested not just check volts), a cable connection issue or a bad cable. If it has a starter relay may want to pull it and check for corrosion also and even swap it out.
I'll check on a starter relay I brought the battery down to the local advanced - had it charged and fully tested yesterday got the printout showing everything on it looks good.
 

·
Registered
1999 Deville Base; 2001 Seville SLS
Joined
·
68 Posts
You likely have a bad connection, such as corrosion inside a cable connector or a loose connection bolt somewhere in the battery-to-starter wiring path. The solenoid's internal contacts also count in that wiring path.
 

·
Registered
SLS 1997
Joined
·
98 Posts
Had the exact same thing. Turn over the key and you'd hear one click. Sometimes the engine would go on in 1 try, sometimes it took 20 times. It drove me crazy figuring out what it was. Because the engine would always go on at some point I didn't suspect the battery. The volts were good until one day I checked and it was only 9 volts. Replaced it and had almost zero problems after. I think mine is leaking somewhere (if that's even possibly).
Next time it doesn't start, hook up some starter cables and you'll know for sure. When mine showed 9 volts I hooked it up to my brother's car and it started right away and it was a solid and fast start. I replaced the battery after that.

Otto
 

·
Registered
1989 Seville STS C&C Build
Joined
·
90 Posts
Discussion Starter #6
Changed out the battery and no success still have the exact same problem it will either start right up or click click starter click until one time it starts like normal. Any other theories on where to go from here, what to check next?
 
1 - 6 of 6 Posts
Top