Cadillac Owners Forum banner

1 - 4 of 4 Posts

·
Registered
1997 STS, 1991 Chevy RC w/500 CAD
Joined
·
115 Posts
Discussion Starter #1
I have a very random and intermittent miss noticed during consistent highway speed. The miss is very light, but noticeable. e.g. on an hour long trip, it may only occur 2-5 times.

maintanence in the last year or so (which hasn't effected the symptom being discussed).

-New plugs
-New wires
-Used lower mileage coil pack/module
-New FPR
-New fuel filter
-Cleaned EGR
-Random fuel treatment (~3x)
-Sea foam in spark plug holes, let sit for few hours.
-Cleaned TB as good as possible without removing it.
-Cleaned MAF


? Possible culprits ?
-Fuel pump
-injector
-vacuum leak (although it idles fine and shows no sign of this)


Please help!

Thanks for your time
 

·
Registered
1997 STS, 1991 Chevy RC w/500 CAD
Joined
·
115 Posts
Discussion Starter #3
No codes.


BUT........

-Just a few hours after writing the O.P. I remembered! I had basically the exact same symptoms with my Vette.

With the Vette, the injectors were maxed out anyways, so they were certainly due for a change whether it be because I had "out grown them" or they were flat worn out.

Needless to say, I did not realize how worn out they were, because new injectors took care of my random misses in the Vette.

My guess is, I have answered my own question. The culprit is worn out injectors.

Thanks

Eric
 

·
Registered
94 Eldorado, and a 99 ETC
Joined
·
3,887 Posts
I hope you're right. Fuel injectors are pretty expensive.

Did you replace the spark plug wires with OEM AC-Delco wires?.... Cadillacs seem to be really picky about that. A lot of generic brands will cause a small miss, or they simply wont last very long.
 
1 - 4 of 4 Posts
Top