Cadillac Owners Forum banner

1 - 7 of 7 Posts

·
Registered
05 Redline CTS
Joined
·
1,007 Posts
Discussion Starter #1 (Edited)
I left my office and drove the 10 mins to the mall, listening to my Sirius radio loudly, and then I went to lower it it and nothing happened .Very odd guys, my radio froze, none of the controls worked, it was stuck on one channel at one volume, and stood on when I turned the car off, even with the doors opened.i turned on and off the car and time disappeared just dashed lines stuck on the same channel and same volume level

So I figured let me turn the car off and go to lunch, I came back in about 25 mins, and the radio was off, I turned on the car on, and it loaded up with the proper custom greeting and all is well, works normal. Drove the 10-15 mins back to work and it worked fine

Background

I have had 2 12’s and amp wired into the rear sub using a high low converter for over a year no no problems, I have had Sirius Radio using an FM modulator.

So I don’t know what that was all about? Anyone else have this happen to them or something like it, if it happens again ill go to dealer but im sure they will blame it my subs of my Sirius

Edit:
Stock no Nav none bose face unit 05 CTS
 

·
Registered
1992 STS / 2005 MB G500 / 2003 STS / 2006 XLR-V
Joined
·
11,694 Posts
Ive heard of that happening before with both the CTS and the Deville/Seville radios. Its just a temporary glitch, I dont think it had anything to do with your mods at all... those radios are part of the communications "bus" and its easy for a small problem to freeze the whole thing.

My 2000 740iL from a while back did the same thing with the navigation system the first week I had it, it was completely frozen... went and saw a movie, came back and it was perfect.
 
X

·
Guest
Joined
·
0 Posts
My screen/wheelbuttons/all functions have frozen around 4-5 times in the 40,000 mi I've driven my CTS. Cadillac says they need to see it happen and then fix it???? Whatever. All control knobs freeze up. Makes me nuts.
 

·
Registered
05 Redline CTS
Joined
·
1,007 Posts
Discussion Starter #4
My screen/wheelbuttons/all functions have frozen around 4-5 times in the 40,000 mi I've driven my CTS. Cadillac says they need to see it happen and then fix it???? Whatever. All control knobs freeze up. Makes me nuts.
wow this is my first time in 65k so i guess im lucky or your unluck, glad to hear other people had this happen

thanks guys :)
 

·
Registered
2003 CTS
Joined
·
174 Posts
A problem I had with my '03's Bose radio only happened once. I was driving around, blasting the must have song du jour... suddenly, the volume cut out in the rear speaker, then a minute later, the rear door speakers went out... a few seconds later, the front door speakers... but the dash speaker stayed on. I was like WTF??? I turned the volume button on the radio... nothing. Turned the wheel on the steering wheel... nothing.

Shut the car off, went into the mall, came out... all better.

Never happened since.
 

·
Registered
2004 CTS
Joined
·
52 Posts
I recently had the FM section of my BOSE system go to one fourth the volume and sound like there was not antenna. They made me remove my sub in the trunk and it still was bad on FM only. They did replace the radio and said this is the first time this has ever happened. :confused: They also said not to add my sub back that would not fix the radio again if it is back. There is nothing that ties the problem to the sub which has worked since May of 04 with no problems.
 

·
Registered
Joined
·
2 Posts
I left my office and drove the 10 mins to the mall, listening to my Sirius radio loudly, and then I went to lower it it and nothing happened .Very odd guys, my radio froze, none of the controls worked, it was stuck on one channel at one volume, and stood on when I turned the car off, even with the doors opened.i turned on and off the car and time disappeared just dashed lines stuck on the same channel and same volume level

So I figured let me turn the car off and go to lunch, I came back in about 25 mins, and the radio was off, I turned on the car on, and it loaded up with the proper custom greeting and all is well, works normal. Drove the 10-15 mins back to work and it worked fine

Background

I have had 2 12’s and amp wired into the rear sub using a high low converter for over a year no no problems, I have had Sirius Radio using an FM modulator.


So I don’t know what that was all about? Anyone else have this happen to them or something like it, if it happens again ill go to dealer but im sure they will blame it my subs of my Sirius

Edit:
Stock no Nav none bose face unit 05 CTS
Yes, it happened to my 2007 cts.
Radio sudsing sound on my fav station. I turned to another station. A few minutes later I went back to the previous fav station and the radio started going off and on for an hour. it is stuck on the same station. I had NO control over the volume or tuning button, i turned the car off and on, no radio panel stayed on after removing my key. However, my door chime and blinkers could be heard when i open my door or while turning corners.

while on this subject..any advice on removing 2 cds from a single playing cd?
Finally, my fV stztion gave a susdsing noise and quickly turned the radio off. It stzyed off. I have not turned ot back on since 4 2 20 in the eve.

(My post ending is out of order after hitting post reply. The last paragraph should be the 4th paragraph).

Joeyblaze
thank you for your reply. Im new to this forum. I will trying starting up my cts and see if its okay this morning.

Note: this is the first my radio gave me trouble in 150,000 miles. Hope it makes someone feel better.
 
1 - 7 of 7 Posts
Top