Cadillac Owners Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter #1
Hi, can anyone tell me what the pump is inside the drivers side front wing , just in front of the front wheel?? Its been disconnected, but when connected it runs and makes the same noise as the suspension levelling motor. It makes a right racket and can be heard inside the car, i think this is why someone has disconnected it , don`t think it`s supposed to be running all the time. Looks something to do with EGR, any ideas ??

Also does anyone know a place over there in the USA that will ship service parts to Britain, it`s a rip off over here!! :( . I had a quote for a new radiator at £300, nearly $600 :eek:
thanks
 

·
Registered
Joined
·
298 Posts
Matt02 said:
Also does anyone know a place over there in the USA that will ship service parts to Britain, it`s a rip off over here!! :( . I had a quote for a new radiator at £300, nearly $600 :eek:
thanks
Try www.rockauto.com. They ship outside the USA. The FAQ at the site explains a bit. Service wise they've been fine domestically so far.
 

·
Registered
Joined
·
1,296 Posts
That pump provides constant vacuum for the cruise control servo. It should only run when the cruise is activated. It can't be serviced or rebuilt, unfortunately. However, it's possible yours is running constantly because of a vacuum leak between it and the cruise control unit.
 

·
Registered
Joined
·
17 Posts
Discussion Starter #4
Thanks for the help, the cruise control seems to work ok even with this unit disconnected.
The car has been seriously neglected in the past , just found out the EGR valve has shot it, and the transmission vac modulator, the list goes on......
Will be posting more of my car problems on here in the future so all the help is really appreciated
Thanks !
 
1 - 4 of 4 Posts
About this Discussion
3 Replies
3 Participants
Matt02
Top