Cadillac Owners Forum banner

1 - 4 of 4 Posts

·
Registered
None
Joined
·
5 Posts
Discussion Starter #1
Car drove good yesterday with the abs and brake light on. Then the reduce engine power came up. I found a lose hose behind the SC area above the TB. Today I tried to duplicate the problem but instead I got two new codes. Now my car wont shift gears stuck on first.

Codes p0700(x2)
P0102
P0689
U0073

If calling some one could be easier let me know. Thanks
 

·
Registered
2006 STS-V and 2007 STS-V The Murdalac
Joined
·
1,905 Posts
Sounds like it might be a power problem. P0689 is a loss of power code and u0073 is a loss of communication code. P0700 is a general transmission code. Could be loss of power to the trans module. Check your fuse box.

Could also be a wiring issue.
 

·
Registered
None
Joined
·
5 Posts
Discussion Starter #3
Okay, ill check the fuse box tomorrow. I've message other forum members about this problem. It seems like i have a electrical issues. Hell..... Ill start with my fuses, then work to finding all the grounds on the car.
Is there a diagram that shows me all the grounds? I've notice my new battery keeps dying after a couple of hours after turning it off. The lights on my dash quickly flash on and off https://youtu.be/cFKY-r8SC7A Also, my engine doesn't turn off right away when pressing the button like my old man 05 Sts. is that normal?
 

·
Registered
2007 STS-V
Joined
·
193 Posts
No, that does not sound normal. Check the main red power cable coming from the battery to the under hood fuse box. It has a large bolt inside the box which connects it to the main 12v buss. This supplies power to all the fuses. It is known to come loose. A poor connection here can cause all kinds of problems.
 
1 - 4 of 4 Posts
Top