Cadillac Owners Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
48 Posts
Discussion Starter #1
Ok, more niggling problems...
So the reading lights in the backseat of my brougham will come on when I open either door, or if I turn all the interior lights on with the headlight switch. However, the lights will not turn on with the switch that is on them. Has anyone else had this problem? Could the switches just be bad in both assemblies? I guess it's possible, since the car is 18 years old. It just seems odd that they both work otherwise.

-Don
 

·
Banned
1995 ETC, 75 Deville, Cad500 powered 73 Apollo, 94 Mark VIII
Joined
·
7,971 Posts
Never had that problem, on my 78 FWB the reading lights don't come on when the doors open, only when you hit the switch. They might have been replaced/repaired and wired differantly at some point.
 

·
Registered
1995 Fleetwood Brougham
Joined
·
709 Posts
I would have to agree with you it sound like the switches. Maybe you could try something likr tuner spray or electric parts cleaner . chances are they're probably just dirty from non use. I have to play with one of mine in my white 85. they both worked fine in my blue 85.
 

·
Registered
Joined
·
6,471 Posts
They use a seperate ground for the switches vs. the door-opening circuit. I'd start there to verify the ground is good. Both may use the same ground and that's why niether works.
 

·
Registered
1991 Cadillac Brougham D'Elegance 5.7 Litre, 1994 DeVille
Joined
·
6,796 Posts
I think on my 91 they only come on with the switches on the lights. Are they supposed to come on with the doors too on older years? Take the panels out and you should see the wiring and tell what's going on. If it is a bad ground you should be able to just run a wire to some nearby metal to fix it.
 
1 - 5 of 5 Posts
Top