Cadillac Owners Forum banner

1 - 12 of 12 Posts

·
Registered
1992 Town Car Cartier & 2014 Accord LX MTX
Joined
·
34,087 Posts
Discussion Starter #1
My Friend has a Talon TSi, and it idles good, but when he takes the E-brake off, it dies. Just before he did this, he sprayed his engine w/ degreaser and a little bit got on the alternator, and I know thats no good for the alternator. Would a bad alternator cause this?
 

·
Registered
1992 Town Car Cartier & 2014 Accord LX MTX
Joined
·
34,087 Posts
Discussion Starter #3
1991 TSi AWD 5 speed manual
 

·
Registered
94 Eldorado, and a 99 ETC
Joined
·
3,887 Posts
Are you sure that's the E-brake and not the clutch? lol... Is the tranny engaged? Are you sure the shifter is all the way in neutral?


I doubt that a bad alternator would cause this.

hmmm, Just wait for it all to dry then maybe the problem will correct itself.. You may have just shorted some wires by putting the liquid on them.

:hmm:
 

·
Registered
1992 Town Car Cartier & 2014 Accord LX MTX
Joined
·
34,087 Posts
Discussion Starter #5
Here is the owner's description of what happens:

As i turn the key...it sounds, and feels normal, as it idles literally at 1000(very normal) then, it shuts off after 7 seconds
 

·
Registered
1992 Town Car Cartier & 2014 Accord LX MTX
Joined
·
34,087 Posts
Discussion Starter #7
I'm not positive, but I'm pretty sure its coils
 

·
Registered
94 Eldorado, and a 99 ETC
Joined
·
3,887 Posts
ohh, i asked because my friend washed his engine (little honda) and water got into the distributor. The car didn't run for a while after that.

Thats very strange... Do you know anything about the way it dies? Does it spudder? If he pressed the gas a little would that prevent it from dieing?
 

·
Registered
1992 Town Car Cartier & 2014 Accord LX MTX
Joined
·
34,087 Posts
Discussion Starter #9
no studdering, no noises, no bad things
 

·
Registered
94 Eldorado, and a 99 ETC
Joined
·
3,887 Posts
Well if it doesn't studder, then that means it's an electrical issue... I doubt it's the alternator though, unless the battery dies with the engine. Maybe it just needs time to dry, the liquid could be shorting out a couple wires.
 

·
Registered
1992 Town Car Cartier & 2014 Accord LX MTX
Joined
·
34,087 Posts
Discussion Starter #11
alright cool, thanks :thumbsup:
 

·
Banned
1995 ETC, 75 Deville, Cad500 powered 73 Apollo, 94 Mark VIII
Joined
·
7,971 Posts
I know I shouldn't be this mean... but yeah he has a problem... HE BOUGHT A DSM!
 
1 - 12 of 12 Posts
Top