Cadillac Owners Forum banner

1 - 4 of 4 Posts

·
Registered
None :(
Joined
·
2,703 Posts
Discussion Starter #1
Haha-hahaha---aaaah!!! Im pissed off now!!


No, apparently it wasnt fixed... light came on again, starts rough sometimes now... im reallly mad. I love the car, but the dealer techs are screwing me 'round and round again. I sent them a letter threatining to tear up the loan agreement, and getting a lawyer if they dont take/fix the car. I took the car back, letting them have it for about a week this time. Think its fixed? Drive it for 40+ miles (my permission) and if the light comes back on again... go back at it. NOT a good thing to do to a guy! It was perfect the first week I had it.. even made a long trip to Daytona from Jacksonville with it and no Check Engine light.

Im guessing that it should work out in the end, i got word that they are complying and that they took it to an actual Cadillac dealer to have it fixed and someones going to drive it for atleast 40 miles to see if the light comes back on again.. and so if it does you know what happens again.

:xevileye: = Dealer Mechanics
 

·
Registered
Joined
·
31 Posts
The '95 Mercury Villager I just traded in always had the check engine light on at highway speeds. When I checked the codes (by shorting it), it flashed EGR valve, and knock sensor (not that that helps anything). Also kinda stupid thing to ask, but are you tightening the hell out of the gas cap? A loose cap can sometimes trigger that stupid light. For the most part the check engine light is for emmissions related things (um, I think?). Have the O2 sensors been replaced? I can't say I blame you for being mad, I have only had my '97 for a week and I am getting a new windshield today (I have no clue what happened to it)! As far a a rough start...what exactly do you mean? If I am helping, cool, if not, sorry.....:canttalk:
 

·
Registered
None :(
Joined
·
2,703 Posts
Discussion Starter #3
Ok well to start with, the gas cap check was done the first time it went in for service... it was good. As far as im told, only one o2 sensor has been replaced and when i did a visual inspection under the car i could spot a new sensor on the right side of the dual exhaust before the cats. The rough start, is more like sputtering... like its trying to go but it just cant until you really floor it... then it clears out. A lil bit of an update, i got a word from the dealer, and they replaced the Mass Airflow Sensor... i dont have the car yet but lets hope this does the trick. :disappoin

Reguardless, i have a good feeling this time! Taking it to an actual Cadillac dealer (even though the dealer string i purchased from doesnt have cadillac) was good of them and im glad they are taking this into strict'r terms. :bouncy:
 
1 - 4 of 4 Posts
Top