Cadillac Owners Forum banner

1 - 9 of 9 Posts

·
Registered
2007 CTS
Joined
·
6 Posts
Discussion Starter #1
Had a leaking line replaced and now the car will barely steer unless you're on the highway. My wife can barely get the car out of the driveway. After searching on here it sounds like there is air in the system but I tried to bleed it based on what I read on here and it didn't help any. Jacked the front end up and went all the way left and right 20 times each with the car off.

What should I try now?
 

·
Registered
2003 CTS 1SC Luxury Sport
Joined
·
1,017 Posts
How long did you let it run while aerating (pump growling)? If you let it go long enough you may have burnt up the pump. Or did you leave VSES solenoid unplugged (assuming you have VSES)
 

·
Registered
2007 CTS
Joined
·
6 Posts
Discussion Starter #3
The pump was working perfectly when the line was replaced and was never low enough to do any damage. I'm wondering if the mechanic did something with the electrical connection on the rack. It does have the variable steering.
 

·
Registered
2007 CTS
Joined
·
6 Posts
Discussion Starter #4
Okay, he's broken one of the wires going to what looks like a solenoid on the rack and pinion. Is this part replaceable and if so how does it come out?
 

·
Registered
2007 CTS
Joined
·
6 Posts
Discussion Starter #6
There's a black plastic cap over the solenoid, is this removable or does the entire solenoid have to come out?
 

·
Registered
2007 6 speed manual tarnished platinum
Joined
·
374 Posts
I'm still on the one it came with, not all of them(most?) have the variable steering option either.
 

·
Registered
2004 Cadillac CTS 3.6
Joined
·
1 Posts
Having the same problem did you figure it out...pump was fine when changed the high hose and now under 10mph I have no power steering...we are at a loss
 
1 - 9 of 9 Posts
Top