Cadillac Owners Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
196 Posts
Discussion Starter #1
96 deville, cleaned the carbon out of the throttle body and now at every red light it stalls unless i brake torque it to keep it from stalling, i need to do a idle re learn, is it done the same way as the 4.9 or is it different cause it being the northstar? or should i jus turn the idle up under the hood...SUGGESTIONS PLEASE
 

·
Registered
1989 Sedan DeVille is now just a fond memory ....
Joined
·
10,429 Posts
The idle relearn is the same. Simply disconnect the negative battery cable for at least one minute.
 

·
Super Moderator
White Diamond '03 DHS (with DTS floor shift)
Joined
·
86,785 Posts
Have you checked to see if there are any DTC's stored?
 

·
Registered
Joined
·
2,250 Posts
take it on the highway (>50mph) for at least a few minutes... see if that helps.

Also make sure you plugged your MAF back in.
 

·
Super Moderator
White Diamond '03 DHS (with DTS floor shift)
Joined
·
86,785 Posts
I'd go back and clean it again. Pay attention to the ISC circuit on the side of the TB. It is an air bypass circuit that allows a controlled amount of air to bypass the throttle plate at idle. Maybe you plugged it with carbon during the cleaning process.
 

·
Super Moderator
White Diamond '03 DHS (with DTS floor shift)
Joined
·
86,785 Posts
Yeah, toothbrush, rags and TB cleaner. Scrub it till it's clean. Don't forget the backside of the throttle plate as well as the perimiter. DO NOT even think of scraping anything with a scraper or anything like that.

I cannot recall from memory where the ISC valve gets the idle air but look for any small openings in the side of the TB bore and be sure they are not plugged.
 

·
Super Moderator
White Diamond '03 DHS (with DTS floor shift)
Joined
·
86,785 Posts
I clean mine in to the end of the TB bore, which is just about as far as I can get my fingers anyway.
 

·
Cadillac Owners Connoisseur
Joined
·
1,164 Posts
So the TPS, MAF, and IAC are all plugged in? Are you absolutely sure? It sounds like either the IAC is plugged up or not working at all. Ranger is right about the IAC air passages. In the TB, you will see a small hole next to the throttle blade on the outside of the intake. That's where the IAC draws air from. That passage has to be clear. Maybe something got in there that's causing the IAC to stick or something. Can you spray some carb cleaner up there? Have you checked for new codes?
 

·
Registered
Joined
·
196 Posts
Discussion Starter #15
Yeah Ive Check For New Codes And Nothing At All, And Everything In There Is Like Spotless Now, But Still The Same Problem
 
1 - 15 of 15 Posts
Top