Cadillac Owners Forum banner
1 - 8 of 8 Posts

·
Registered
Had a Cadillac
Joined
·
169 Posts
Discussion Starter · #1 · (Edited)
Ok I searched for this issue, but didn't really find any great or useful information, everybody just chimed in and said they had this issue. I am strongly considering of getting rid of this car. I cannot drive with this noise any longer.

I saw that BlackCadillac91 started a thread about this:
So here are the symptoms:
A dull rattling noise coming from the front end when going over bumps.
Seems to only happen at lower speeds (under 40mph or so) on "sharper" bumps. Not little dips in the road but a rut or hole (unavoidable in jersey ) will cause the sound.

I've read all of the threads on similar issues and some said that it could be a loose brake component of some form? This does not make sense to me but what do you guys think? I always assumed it was my struts and since im replacing them anyway I never really considered it to be a big issue
I have the exact same issue. I went to the dealer and had them ride along with me. The took it in and took apart the whole dash area. They said they couldn't find anything so put the dash back together... the rattle did stop for about a week, but slowly came back and now it is rattling as it was in the beginning.

Here are some of the solutions others have given:
Here are the two items that caused noise for me: The plastic cover under the car near the front was cracked and loose. I taped it and added some screws and it stopped.

The stabilazer bar was loose in the rubber supports, I could see light around the bar so I took some ziptyes and shoved them in there temporily to see if the noise goes away, it did, the zip tyes are still in there two years later, LOL
AND

mine did the same thing after the dealer replacing bushings ball joint one tie rod,none of them fixed the problem, then they replaced the srtuts which cured the issue.
Does anyone have an update or a definite solution for this issue before I take it back to the dealer for another look?
 

·
Registered
03 CTS 3.2L (Sold) / 09 CBR 600rr /2014 GMC Sierra
Joined
·
7,872 Posts
if you think its the sway bar bushings try replacing them yourself, its only 2 bolts each.
you can buy them for about $12
 

·
Registered
Had a Cadillac
Joined
·
169 Posts
Discussion Starter · #3 ·
Thanks Mike. I'll note to do that. I'm compiling a list of all the possible things that could be done and hopefully fix it for good.
 

·
Registered
03 CTS 3.2L (Sold) / 09 CBR 600rr /2014 GMC Sierra
Joined
·
7,872 Posts
No prob.
I'm going to be buying ones with grease fittings for mine. They aren't really vehicle specific, you just need the diameter of your sway bars and the bolt spacing range for the bracket.
I was looking at them on ebay, I just gotta get a friend to agree to install them for me...I can't bend and get under the car, but its a easy install.
Just make sure to use jackstands and lift the front on both sides...they are pressurised a little.
 

·
Registered
2003 CTS
Joined
·
2,337 Posts
i had a bad front strut that would make a dull sounding noise. you could see fluid on the outside of the strut. it wasnt dripping or anything, but you could tell it was leaking.
 

·
Registered
2006 CTS-V
Joined
·
4,969 Posts
You can get a creaking noise from the control arm bushings. Just throwin that out there as well.
 

·
Registered
Had a Cadillac
Joined
·
169 Posts
Discussion Starter · #8 ·
Thanks for all the leads on this issue. I will update this thread if I make any progress on this. Hopefully I find the source and I can let others know because this seems to be a problem on quite a few CTSs.
 
1 - 8 of 8 Posts
Top