Cadillac Owners Forum banner

1 - 3 of 3 Posts

·
Registered
1993 Seville SLS
Joined
·
5 Posts
Discussion Starter #1
Gents:

'93 Seville with the 4.9... The under-dash engine computer module (pcm?) - mechanic said I needed a new one.

Grab one from salvage yard, and then plug and play? Do-able? Re-programming needed or anything?

Any help or info appreciated.

Thx........ M.
 

·
Super Moderator
White Diamond '03 DHS (with DTS floor shift)
Joined
·
86,783 Posts
Not sure if it will be plug n play. It may need to be flashed with your VIN by a dealer.
 

·
Registered
1993 Seville SLS
Joined
·
5 Posts
Discussion Starter #3
Update...

Well, I tried the P&P method, not realizing to switch out the internal chip first. Donor PCM in, old one out... The security mode kicked in and disabled the starting. (I plead ignorance.)

So, upon further research and a torx screwdriver, I swapped out the donor's chip with the one from mine and tried again. After about 5-6 starting attempts, once it decided to fire, it ran and idled normally and nicely. Smooth on throttle. The miss and running problem... gone - for about two minutes. Then, wacky stuff started happening... revs jumping up and down, new codes appearing that weren't there before, hard starting, and the idle control motor clicking around like crazy. So, is it safe to assume that the new PCM is just as bad as the old one, or does the thing need time to "re-learn" the new motor?

Strangely, when I put everything back the way I previously had it (old PCM re-installed w/original chip), we're running smooth and normal again for about 100 miles or so. Now, the miss and rough running have returned. This is making me nuts.

Any ideas? Thx.... M.
 
1 - 3 of 3 Posts
Top