Cadillac Owners Forum banner
  • Hey everyone! Enter your ride HERE to be a part of August's Ride of the Month Challenge!
1 - 3 of 3 Posts

·
Registered
deville concour
Joined
·
8 Posts
Discussion Starter · #1 ·
Hi Guys, i had a problem with my concours 1996 i had jumpstart it , and now i have replaced alternator the battery and it still discharging can you help me?
papaearle:hmm:
 

·
Registered
deville concour
Joined
·
8 Posts
Discussion Starter · #3 ·
thanks amencaddy sorry for getting back to you so late.i'm still working on it, i took it to a elec shop they coudn't help me tthey had it half a day they didn't charge me ,i'll let you know what i find if i do
papaearle:crying2:
 

·
Registered
deville concour
Joined
·
8 Posts
Discussion Starter · #5 ·
HI, Amencaddy finaly getting back to you,my problem is repaired. I went back to that shop and add the alternator check ,we put it on the tester and it showed good.I finally talked him in to giving me another one to try, SO i hooked up the new alternator and it charged good,so he took mine and sent it to another shop they sent it back with a new regulator install. he was very good
with me he let me keep the new alternator, it was new from dealer not rebuilt for my troubles. I don`t really blame him after seeing the tester showing good, so thats where we are at now hes sending his tester in to be checked, so i`ll follow up with the answer on that thanks amencaddy papaearle
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top