Cadillac Owners Forum banner

1 - 6 of 6 Posts

·
Registered
Cadillac
Joined
·
40 Posts
Discussion Starter #1
2 weeks ago noted significant gas leak from above tank on 07 escalade. Took tank down and fuel pump rusted badly and replaced. This morning getting error P0451 Evaporative Emission System Sensor engine light. Truck seems to drive find and no leak of gas. Suggestions?
 

·
Registered
2009 escalade hybrid
Joined
·
3,710 Posts
David999 said:
2 weeks ago noted significant gas leak from above tank on 07 escalade. Took tank down and fuel pump rusted badly and replaced. This morning getting error P0451 Evaporative Emission System Sensor engine light. Truck seems to drive find and no leak of gas. Suggestions?
Reset the battery?
 

·
Registered
Cadillac
Joined
·
40 Posts
Discussion Starter #4
I erased the code and all good. How often does the escalade run the test that would display this code if something is indeed wrong
 

·
Registered
2009 escalade hybrid
Joined
·
3,710 Posts
David999 said:
I erased the code and all good. How often does the escalade run the test that would display this code if something is indeed wrong
You can erase the code by disconnecting the battery. If it's still there after the ecu resets itself then it's really a code.
 

·
Registered
Cadillac
Joined
·
40 Posts
Discussion Starter #6
I reset the code and 7 days later the same code appeared. Spectra Premium fuel pump assembly replaced about a month ago as original was rusted at top and leaking. No further leaks and car seems to drive fine. What could be causing this code to reappear and what parts should I replace if fuel pump ok when I take tank down today..
 
1 - 6 of 6 Posts
Top