Cadillac Owners Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
151 Posts
Discussion Starter #1
Hi,
My check engine light came on and I read these two codes. My understanding is that they mean, "System too lean Bank 1" and "System too lean Bank 2". If this is correct, can someone tell me what this means, and what I should do about it.
Thanks,
John
 

·
Registered
78 Deville 10 CTS-V Sedan M6 10 SRX Turbo Premium
Joined
·
252 Posts
It could mean a couple of things, You could have a couple of faulty 02s, you could have a vaccum leak. How many miles are on your car? Does it idle fine?
 

·
Registered
Joined
·
151 Posts
Discussion Starter #3
Hi Jeb,
There's about 60,000 miles on it. I should mention that the car has been running very rough when cold, for the past couple days. It hasn't stalled out but it seems like it wants to. Once it runs for a couple of minutes it's fine. The temperatures here is around freezing.
I have also had, what I think are, gas cap problems in the past. Could this be caused by a poor gas cap seal?
Thanks,
John
 

·
Registered
78 Deville 10 CTS-V Sedan M6 10 SRX Turbo Premium
Joined
·
252 Posts
Humm, That is odd. I would rule out the gas cap. Some were there is unmetered air getting in there. Are all of your intake hoses tight and in place?Are all of your intake plentum bolts tight?
If that is not the case I have no clue, I bet it is something minor.
 

·
Registered
Joined
·
190 Posts
you might want to give this a try unplug the mass air sensor and see what that does. cause it will go and you will have some problems
 

·
Registered
Joined
·
151 Posts
Discussion Starter #9
Thank you all for your help. I took it to my mechanic this morning. He changed the fuel filter and flushed out the injectors. He also said that my code reader, the Innova 3100, read the wrong codes, that when he checked it P0174 and P0171 did not show up at all. I don't remember what the codes he got where.
John
 

·
Cadillac Technician
none
Joined
·
11,051 Posts
Rough idle on cold starts and lean codes on a Catera usually mean a bad MAF sensor.
They register an incorrect amount of air passing into the engine and cause this type of problem.

Hopefully yours is fixed. I don't think MAF sensors are cheap. I have replaced many for these very symptoms.
 

·
Registered
Joined
·
151 Posts
Discussion Starter #12
ewill3rd said:
Rough idle on cold starts and lean codes on a Catera usually mean a bad MAF sensor.
They register an incorrect amount of air passing into the engine and cause this type of problem.

Hopefully yours is fixed. I don't think MAF sensors are cheap. I have replaced many for these very symptoms.
Hi Ewill3rd,
Does clogged injectors also make sense?
John
 
1 - 12 of 12 Posts
Top