Cadillac Owners Forum banner

1 - 4 of 4 Posts

·
Registered
Cadillac
Joined
·
10 Posts
Discussion Starter #1
So last night i was leaving dinner and got a couple miles up the road and the DIC had a message that said engine hot/ ac off. Temp gauge was not reading at all. I checked to make sure i wasn't out of coolant and everything looked fine. Fans were running on high. My neighbor is a diesel tech but has a nice scanner so i had him hook it up. Car did not throw a CEL but there was a code p0128 stored. The car had cooled off before taking it to him but as soon as i started it the same message came on DIC and fans on high. We could see through the scan tool the temp sensor was reading. Was staying around 120 sitting in his driveway. From what i have read the reason for this code is either thermostat or temp sending unit. Since his scan tool is getting a reading from the sending unit i'm assuming thermostat is stuck open.

Changing the thermostat is no big deal but is there a way to know if the car already had a 160 in it? I bought it used from a dealership and it had a cai, upper pulley, and corsa exhaust that are obvious mods. I feel sure the car has a tune but no clue who tuned it and if it had a 160 tstat installed prior to this. Since the code was present and no cel does that mean anything?? I was going to just pick up both and hope there was a marking on the one i pulled out but the local parts stores only list a stock 187 so if i need a 160 i will have to order it. I don't want to install a 160 only to find out its not tuned for that and then have to do the job again but if its already setup for that then i want to go back with that. Any suggestions??
 

·
Registered
Joined
·
277 Posts
The car had cooled off before taking it to him but as soon as i started it the same message came on DIC and fans on high. We could see through the scan tool the temp sensor was reading. Was staying around 120 sitting in his driveway.
That code is saying the engine did not reach an expected temperature in a set amount of time based on input from multiple sensors. You may have an issue with your fans. They are programmed to not engage until 225º in the factory tune, and cannot be set lower than 195º with the standard PCM operating system. You might try unplugging them for a while and see if normal temperature operation returns.
 

·
Registered
Cadillac
Joined
·
10 Posts
Discussion Starter #3
That code is saying the engine did not reach an expected temperature in a set amount of time based on input from multiple sensors. You may have an issue with your fans. They are programmed to not engage until 225º in the factory tune, and cannot be set lower than 195º with the standard PCM operating system. You might try unplugging them for a while and see if normal temperature operation returns.
The fans are directly related to the code. When the code comes on the fans default to high. I guess its a safety thing but as soon as code is cleared fans turn off. In my searching i didn't see anyone else with 09+ v with this problem but lots of other gm cars have same thing and the fans run on high when the code is present.
 

·
Registered
Joined
·
277 Posts
The fans are directly related to the code. When the code comes on the fans default to high.
Are you sure it's not the other way around? The code is saying that the engine did not reach a high enough temperature for the length of time it was running. The ECT is not too hot, it's too cool.
 
1 - 4 of 4 Posts
Top