Cadillac Owners Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Vehicle is new to me and a crackhead owned before me is my best guess given the amount of drug paraphenalia ive found. Bought from junkyard. All complete except missing dash cluster. Upon pulling from another escalde 3 different times 3 diff escalades times and all three clusters did the same thing as im still experiencing. Which leads me to believe not faulty cluster? Check engine light is illuminated the curly q light that appears as an upside down "w" is lit and the left blinker when activated blinks. Nothing else happens no reset of gauges upon start nothing. Lights that are illuminated will flicker upon driving on bumpy roads. Note when i start truck if i slowly turn key the drive info screen will turn on along with radio but thwy go off when engine starts. Note also locks will go lock unlock when they feel like it . sunroof will work not work. No seat controls however heated seats will turn on at will. Ive been all over the trucks grounds trying to eliminate that. Cruise control works as do both blinkers but only left shows in cluster. P0650 code cOME
s up and prior to erasing so did a steer wheel angle code but has not returned radio played prior to me causing issue with factory amp. NOTE BOTH CHECK ENGINE LIGHT AND CURLY UPSIDE DOWN W STAY ILLUMINATED WHEN KEY OFF! In regards to factory amp i attempted to bypass . worked great for a day then burnt amp out . would like to bypass amp compleltely thinking i could pull wires right from amp plug in to my amp but trying to find the right wiring diagram via internet has proven virtual impossible for 02 escalade
I do believe i have found right one which sais 03 mazda upon the pic.am i wrong to think i can use the pos and neg and for my preamp from factory harness along with amp turn on? But the description of wires are not that ive ever seen before so determining which goes to what has proven to elude me. Love this truck runs great but its driving me nuts and where i live i do have a cliff but never want to admit my vehicle who really has no ability to physically beat me with me allowing it makes me grind on to figure this thing out? Any help is most graciously appreciated!!!
 

·
Registered
02 Escalade,96 Aurora,with Shelby engine
Joined
·
586 Posts
start with a brand new fresh battery rated for your Caddy,and clean cable/terminals.
What year are the clusters youve tried?
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
Ive jist come to realize that might be part of issue . when i swapped out clustwrs i wasnt paying attention to the years due to pure ignorance. I jave changed tje battery and cables. Im kinda leaning toward a bcm as the culprit.
 
1 - 3 of 3 Posts
Top