Cadillac Owners Forum banner

1 - 7 of 7 Posts

·
Registered
1993 Seville 4.9 150k
Joined
·
25 Posts
Discussion Starter #1
Help!!
Did pretty comprehensive tune on my 93 Seville with 4.9 motor.
Noticed the mileage dropping, thought I ought to go ahead and replace 02 sensors b-4 I got the check light. Car has 101K on it.
I bought two, found the one near the fan at the front of the engine compartment. Now where in the heck is the other one?
I am guessing near the firewall, but I can find no trace of the sensor back there.
Was able to pull the front one and replace fairly easily, but I can't do the other - makes me nuts leaving it undone. Any help?
Thanks:crybaby:
 

·
Registered
Joined
·
176 Posts
I'm pretty sure there ONLY is one. The devilles had one, and I belive the seville and eldorados both got two. I seem to remember another thread related to this somewhere, but I know my 92 deville only has one, and the 93's are more or less the same.
D.
 

·
Registered
Joined
·
176 Posts
Wait..... if you found one up front near the fan then maybe you do have two... The other one should be on the rear, on the downpipe going from your manifold to the cat, easist to see from under the car (if you have the luxary of a lift :) ).

D.
 

·
Registered
1993 Seville 4.9 150k
Joined
·
25 Posts
Discussion Starter #4
HippieD9 said:
Wait..... if you found one up front near the fan then maybe you do have two... The other one should be on the rear, on the downpipe going from your manifold to the cat, easist to see from under the car (if you have the luxary of a lift :) ).

D.
Well, a lift w/b excellent, but I have to settle for hydraulic jack and stands.
I was afraid of having to crawl around, but figure if I can get those back four plugs in and out, I can do this also.
BTW, I bought the sensors for $24/each at Autozone(Bosch).
They told me a special tool would really help. But, they are not super-torqued, and a 7/8" box handles this easily.
Thanks very much for the feedback.
 

·
Registered
2001 DTS, 2005 Mustang GT, 2010 MINI S
Joined
·
1,121 Posts
The '93 Seville 4.9L has 2 O2 sensors. Plain and simple. Earlier Devilles did only have 1.

The Bosch O2s will work fine on the OBDI cars. Bosch is the company that invented the O2 sensor.

OBDII cars really need the GM O2 sensors to work properly and not set codes.

Logan
 

·
Registered
1993 Seville 4.9 150k
Joined
·
25 Posts
Discussion Starter #6
Logandiagnostic said:
The '93 Seville 4.9L has 2 O2 sensors. Plain and simple. Earlier Devilles did only have 1.

The Bosch O2s will work fine on the OBDI cars. Bosch is the company that invented the O2 sensor.

OBDII cars really need the GM O2 sensors to work properly and not set codes.

Logan
Logan -
Wierd - I just ran across your website yesterday. I plan on sending down my third brake lite in Spring to have it fixed. I checked for the crushed harness, and no dice. Funny thing, tho, when I have my son step on the brake, the section that won't lite lites when I rap on it with my knuckles...
Hopefully you won't bang for $500 like getting a new one.
 

·
Registered
2001 DTS, 2005 Mustang GT, 2010 MINI S
Joined
·
1,121 Posts
The lamp has an internal failure at the circuit boards. Cadillac is very proud of the LED lamps at a current price of $421 +tax and labor. Wow....

Cadillac did not build the lamps. They are made by Stanley Electronics.

You get one shot at fixing the lamps. They are a sealed unit. They have a double sided circuit board. There are several other posts about resolding the boards......it simply does not work. Cadillac at one time had a TSB and dealership video on a 'temporary' repair procedeure. Resoldering....

We had somone on this site send us their 'resoldered' lamp. After 14 days or so and shipping via USPS the lamp was in failure mode..

http://images.andale.com/f2/115/106/3768672/1071026717340_fail_002.jpg

We modified the electronics, and repaired the housing, vacuum checked.....

http://images.andale.com/f2/115/106/3768672/1069315111978_fail_010.jpg

Theres another lamp we repair...the Acura NSX LED brakelight. Also made by Stanley. These owners dont dick around...they want somebody to fix them that 'has been there done that.' They are $1000 new from Acura.

http://images.andale.com/f2/115/106/3768672/1034866547569_leds.jpg

The Acura one is on the right.

Logan
 
1 - 7 of 7 Posts
Top